lost in the second monitor

Dec 9, 2008 at 10:11am

lost in the second monitor

hello out there,

I have a funny problem:

if I have used just temporarily an extern LCD-monitor when I was saving a MAX patch on my MBP –> I can not reach all the MAX windows of this patch anymore without this LCD-monitor.

is there a trick to say MAX: “hey you have now only one monitor anymore! — please move all windows back to this monitor!” ?

the same problem I have with LOGIC and other software.

[MAXMSP 5.5, MACOSX 10.5.5.]

thanks!
bd

#41259
Dec 9, 2008 at 10:20am

Yes, i already had this as well, but not with Max.

Sometimes simply changing your screen resolution to another settings, and then back again will force the app to move your window to the main (and only) monitor.

Hope it helps

ph

#146724
Dec 9, 2008 at 10:21am

#146725
Dec 9, 2008 at 10:25am

#146726
Dec 9, 2008 at 10:56am

#146727
Dec 9, 2008 at 11:03am

close all windows, even when you don’t see them. restart. shoudl work then, in most cases.

#146728
Dec 9, 2008 at 11:50am

hello to you all,

thanks a lot !!

I will try out the different tricks.

best,
bd

#146729
Dec 9, 2008 at 9:44pm

FYI, the nvidia nView desktop management software has functionality for
sending windows to different connected displays.
It’s great for “sucking” back windows from software that doesn’t have
the great functionality of Max.

(they also did the “Spaces” thing many many MANY moons ago, and still do)
Andreas.

#146730
Dec 10, 2008 at 12:38am

You can also have an emergency “window size 0 0 200 200, window exec” message attached to a [thispatcher] in all your potentially wayward windows. Trigger them with a keystroke or a send from a patch which stays in the main monitor. In this case, your window should jump to the top left of the main one and become 200 x 200 pixels in size. Tweak as desired, or save presets of precise size and positioning of your windows.

I needed to do this for a vj setup where the second monitor was projecting the visuals, and there wasn’t a title bar on the window (so no way to manually move it with the mouse). I got the positioning and size just right (for whatever projector I was using) using a control panel in the main patch (a pack object for the 4 coordinates), then could recall that as a preset.

–CJ

#146731
Dec 10, 2008 at 2:18am

One thing worth trying is using the ‘activate spaces’ key command in Leopard. It is F8 on my keyboard, I can’t remember if thats the default…but you can set it in system preferences/spaces. The key command will zoom out to show all of your ‘spaces’, and you can move windows around…even between monitors.

#146732
Dec 12, 2008 at 12:55pm

Hi everyone,

I had a similar problem and I found that with another parcher open alt clicking the small green ‘+’ circle on the to of the window (or maybe it was the orange ‘-’) gathers all windows back onto the main screen.

Hope that was of some help,

Chris.

#146733
Dec 13, 2008 at 1:12pm

Quote: bdhm wrote on Tue, 09 December 2008 11:11
—————————————————-
> if I have used just temporarily an extern LCD-monitor when I was saving a MAX patch on my MBP –> I can not reach all the MAX windows of this patch anymore without this LCD-monitor.
—————————————————-

This has been billed as a “feature” in Max for almost twenty years.

At least on Mac OS, it has always been an application’s responsibility to (1) store window position and size as part of the document on Save and (2) check the stored dimensions against the current screen geometry on Open. If the stored coordinates are off screen, the app is supposed to move the window on screen.

Many applications diverge from the ‘canonical’ behavior in different ways. After years of complaints to Cycling ’74, someone added code to Max implementing the option-select-patcher-from-Window-menu technique. That’s the official way to solve your problem.

#146734
Feb 22, 2009 at 10:51am
Nick Inhofe wrote on Tue, 09 December 2008 19:18
One thing worth trying is using the ‘activate spaces’ key command in Leopard. It is F8 on my keyboard, I can’t remember if thats the default…but you can set it in system preferences/spaces. The key command will zoom out to show all of your ‘spaces’, and you can move windows around…even between monitors.

hi,
yes this is the best resolution for me.

thanks to you all!
bd

#146735

You must be logged in to reply to this topic.