Forums > MaxMSP

LPD8 Problems

January 22, 2013 | 9:16 am

Hi,

I’m relatively new to max and have been having some problems with getting an Akai LPD8 Pad Controller to function in a patch I’m building.

Max detects a signal (via notein and stripnote) but I can’t get it to activate a toggle or function in any other useful way. The patch (as it stands) is below:

– Pasted Max Patch, click to expand. –

I imagine there’s something really obvious I’m missing. If anyone can point this out, I’d really appreciate it.

Cheers!


January 22, 2013 | 9:35 am

Morning,

Cant see your patch because im at work, so could be way off…..but

The pads could be sending out a ‘control MIDI messages’ rather than the ‘MIDI note messages’ that you are expecting.

try using the ‘ctlin’ object, it gets all the data from your knobs, faders, pads etc.

If thats no good ill check the patch out later when i go home and try and repost.

All the Best,

Oli


January 22, 2013 | 10:51 am

Thanks for dodging your work to help! I didn’t have any luck with ctlin…I can get the controller to trigger a button when I connect it – via route – but it’s not having any effect on the toggle. Having said that, if I connect the right outlet of route to the button, the toggle will work when I click any of the pads (other than the one I’ve routed) – which is, I guess, what it’s supposed to do. But…I just want to have a specific pad routed.

Anyway, it’s not easy to put into words, so hopefully you’ll have better luck when you see the patch.

Many thanks in advance!

Ross


January 22, 2013 | 11:00 am

Hi,

I will post a patch to you around 12ish,

Regards,

Oli


January 22, 2013 | 12:09 pm

here’s what I did when I used an LPD8:

– Pasted Max Patch, click to expand. –

January 22, 2013 | 12:33 pm

This does what you have asked.

let me know if you need something else;

Regards,

Oli

– Pasted Max Patch, click to expand. –

January 22, 2013 | 7:47 pm

Hi guys,

Oli – I see it was the sel object I should have been using – that’s made everything much clearer now. Thanks for your time!

Liam – thanks for the patch…that’s saved me figuring out the next step of routing the individual dials.

Much appreciated!!

Cheers,
Ross


January 22, 2013 | 8:00 pm

your problem was the routing you’d done with the number boxes, actually – effectively doubling the message, so it would turn on then off again immediately.


January 23, 2013 | 9:03 am

Ah, OK thanks. That explains a lot!


Viewing 9 posts - 1 through 9 (of 9 total)