Forums > Max For Live

Making A Visually Responsive EQ

February 6, 2013 | 7:27 am

Hi,
I am trying to make a visually responsive EQ, like on a stereo, that shows the levels of the different sound frequencies. Here is what I have found and cobbled together. My question is why the faders on my patch do not match up with the visual display on ableton, like in the Spectrum audio effect. I would really appreciate another set of eyes to look at this and let me know why the sliders don’t match up.
Thanks

– Pasted Max Patch, click to expand. –

February 6, 2013 | 7:40 am

Errr. I guess that looks like it works enough but for some reason some frequency bands, like at 100 Hz are always on. Any idea why that is?


February 6, 2013 | 8:27 pm

You’re using a really high Q on your bandpass filters. High Q filters have high resonance which makes them very prone to ringing.

I recommend using cross~ instead. You’d need to expand the number of bands, but this should work quite well.

– Pasted Max Patch, click to expand. –

February 8, 2013 | 4:57 am

I did private message you but, in case you didn’t see:
When I make it into a M4L device and turn it on, it distorts the sound. Could it be from all of the plugs going into the L/R channel of the plug in/plugout connection? Also, could you help me through the latency calculation you mentioned?


February 9, 2013 | 6:14 pm

Did some testing on the latency thing, and looks like it’s not the issue I thought it was. You could omit that.

This works fine for me without distortion:

– Pasted Max Patch, click to expand. –

February 10, 2013 | 12:27 am

Hi Peter,
First, thanks so much for your help. I have learned quite a lot from what you have already posted, as I didn’t know too much about eqs before now. I just have one last question, when I use live as the sound source, and go from the l and r plugin~ through the cross filters and then out through the l and r plugout, it still amplifies the sound.
When I turn off and on the cross eq object, I can see a rise and drop of about 5dB. Since the cross eq doesn’t use gains, I am not sure what would cause this or how to correct it. It is still better than what I have so I can use it if I have to, but I would really like it to only change the sound level if I adjust the sliders (and not change the sound level if all sliders are at zero). Any ideas? Thanks again, I really, really appreciate it.


Viewing 6 posts - 1 through 6 (of 6 total)