Forums > MaxMSP

making an App + bad freeobject


JMF
February 15, 2010 | 8:04 pm

Hi everyone,

I’m creating an App and constantly apears at the end of the build
3 errors
freeobject: 23482a00: bad object
freeobject: 23482d18: bad object
freeobject: 23482a70: bad object

each time I make a new build the numbers and characters change…

the app seems to work well in several computers (all OSX 10.5 or higher)


February 15, 2010 | 10:45 pm

Are you using any third party objects?



JMF
February 17, 2010 | 10:20 pm

wow!!!! – " it had to be you "
I’m using OSC-bcf2000.js written by John MacCallum from your library ejies 2.0b2
it is, obviously, credited (don’t worry) and I’ve tried the app with my bcf2000 and it worked fine…


February 17, 2010 | 11:12 pm

OSC-bcf2000.js is part of the CNMAT library, not from the ejies, and I’m not John ;-) Besides that, if you have a patch of example that might be interesting to look at it.



JMF
February 17, 2010 | 11:34 pm

well… its strange, i must have my libraries all messed up…
when I open a patch using OSC-bcf2000.js it announces on the max window
"ejies 2.0b2 (10/2008)
by Emmanuel Jourdan, Ircam"

I know it was written by John… and of course I also use ejies…
i’ll send the patch that "acuses" your library.

– Pasted Max Patch, click to expand. –


JMF
February 17, 2010 | 11:40 pm

I’m Sorry Emmanuel, that one is just a simple patcher using OSC-bcf2000.js
i’ve already made an app with this object and it did not acused any… "badobjects"

at this point i have the main patch… but I use a lot of externals… should I use a collective? (and put it here?)


February 18, 2010 | 12:39 am

Please use "Copy Compressed" for posting patches (it’s a condensed format made especially for that matter). If you want to figure out where the error comes from you just want to remove externals one by one to find the culprit, which is unlikely to be from the ejies, as it’s only abstractions and js/java :-)



JMF
February 21, 2010 | 11:24 pm

ok, that’s a great effective ideia!!!
thanks a loT



JMF
February 22, 2010 | 2:19 am

guess I’ve found the problem…
after reviewing all the externals, i’ve simply tried to build using the "include file" feature instead of the "include folder" – and it didn’t report any error…
it seems that I was including the main patch twice (I kept everything on the same folder!!!!)
taking out the main patch from the folder resolved all the problems…

is this supposed to be like this?

thanks again, in advance…


Viewing 9 posts - 1 through 9 (of 9 total)