Forums > MaxMSP

Making record~ user friendly in presentation mode

May 16, 2013 | 10:11 am

Hello there,

I am trying to figure out a way of making the record~ object more usable in my presentation mode. At the moment, you must type in the ID that I have assigned to the buffer~ and groove~ objects into the record~ object to record a sound for each. I know there must be a solution to this that I am completely overlooking. Any tips or suggestions would be greatly appreciated.

Thank you in advance!

Sasha


May 16, 2013 | 10:50 am

Try this…uses [textedit] or [umenu]. Note the prefix settings for [umenu]


May 16, 2013 | 11:03 am

Hi John,

Thank you so much! I knew umenu had to be the answer!

Once again, I really appreciate your help — thanks!


May 17, 2013 | 9:51 am

unsubscribe


December 11, 2013 | 12:33 am

<code>

– Pasted Max Patch, click to expand. –

</code>

Copy and paste that into a new patch. You had the patch chord from the Umenu going to the wrong inlet of record~. (you can copy compressed by selecting everything in your patch and selecting copy compressed from the edit menu)

You might also check out sprintf for combing symbols like samp and 1. That way you can name buffers samp1, samp2, samp3 and call them by feeding them that number.(The Umenu method works just as well) Dr. Mark Phillips figured that out for me. He has a wealth of excellent tutorials on his website. You might also look into how to create quick fades in order to avoid clicks in the audio. I can post examples at some point if necessary.

http://www.ohio.edu/people/phillipm/public_html/MaxResources.html


Viewing 5 posts - 1 through 5 (of 5 total)