Manual step sequencer problem

Jan 10, 2012 at 1:18am

Manual step sequencer problem

I’m trying to make a manual step sequencer out of the built-in Max version, and I’ve gotten pretty far but for one little problem – when I load a preset it triggers the first note already.

Can you help me figure out how to stop it sending that first note on preset change?

NB. This sequencer doesn’t sync with Ableton but has been designed to step forward with a button or MIDI input – note C-1.

– Pasted Max Patch, click to expand. –

`
(NB. Mirrored here – http://forum.ableton.com/viewtopic.php?f=35&t=174956 )

#61135
Jan 10, 2012 at 8:12am

the numberbox called “position” just after the counter is connected to the preset engine, so every time you recall a preset it outputs the zero.
Connect the third output of the Preset object to it and that should cure your ails.

#220328
Jan 10, 2012 at 10:21am

Thanks Wetterberg – think that’s closer but I’m still getting a note playing on preset recall after connecting that 3rd output – sometimes the note seems to ‘stick’ too …. maybe I need to exclude something else from the preset as well?

#220329
Jan 10, 2012 at 10:31am

Maybe this is overcomplicating it but perhaps I could add a variable that says ‘only play a note after receiving MIDI note C-1′? I’ve no idea how to do this though, total noob here!

#220330
Jan 10, 2012 at 11:01am

well, you need to resave the presets first – it’s not enough to just connect it.

#220331
Jan 10, 2012 at 11:06am

Mm, seems to happen with new presets too. Haven’t had much luck with my ‘gate’ work-around either. Rehearsal is in 2 hours and I badly need to fix it! :#

My next problem is stuck notes when changing patches! Is there any easy way I can send a “kill all notes” on preset change?

#220332
Jan 10, 2012 at 11:17am

I have been testing it, it definitely isn’t outputting new notes. I’m stumped as to why yours is. I wonder if I should save it for you, because I can tell that there are no notes being generated.

I just came up with a way of handling this in a hack-around, though. See attached.

Re: the kill all notes: I’d switch to just using a makenote, if you’re worried about the time-scale of it.
[Borax] gives you ways of killing all notes, btw.

– Pasted Max Patch, click to expand. –
#220333
Jan 10, 2012 at 11:21am

Well the following patch has BOTH those mechanisms implemented. Again, I just tested and this appears to work.

– Pasted Max Patch, click to expand. –
#220334
Jan 10, 2012 at 11:24am

Ok this looks cool – do I replace the bit next to the ‘noteout’ with it – input notes to the ‘pack 0 0′?

#220335
Jan 10, 2012 at 11:26am

put all this in where the [noteout] was – so this connects to that thing called step.overlay.

#220336
Jan 10, 2012 at 11:28am

Ah, sweet silence! I don’t know what you did but that killed it! Now to have a look at Borax :)

#220337
Jan 10, 2012 at 11:31am

what this little critter does is :
Every time you load a new preset it shuts a gate.
The note coming down (that first errant one) then fails to enter, and immediately opens the gate.
next one then passes freely.

Good luck with borax – it’s a great object :)

I’ve done stuff with “manual sequencers”, and in those cases I only use the pitch value – that is, the incoming midi is then used for the velocity and note-on/off, so that you can scroll through the sequence, while still controlling the velocity. Pretty fun.

#220338
Jan 10, 2012 at 11:33am

Nice one… just got one problem – I’m now missing that first note when loading a preset!

#220339
Jan 10, 2012 at 11:35am

that must be because BOTH fixes are working. Simply remove either of them, I guess.

#220340
Jan 10, 2012 at 11:37am

By both fixes, you mean the ‘exclude from preset’ too? I’ll give it a go..

#220341
Jan 10, 2012 at 11:44am

Ok, if I remove the ‘exclude from preset’ I get a nasty stuck note when loading presets. If I remove your gate patch I get the same.

But with both enabled I lose the first note of the sequence! So mysterious..

#220342
Jan 10, 2012 at 11:50am

sorry man. I don’t know what to say at this point. I’m all out of time for testing this, I’m afraid.

#220343
Jan 10, 2012 at 11:50am

Ok no worries, thanks for your help.

#220344
Jan 10, 2012 at 6:58pm

Ok I figured it, just had to add one more element to the ‘exclude’ link! :)

#220345
Jan 10, 2012 at 7:19pm

u could make that extra note a special feature of your app.

“the mysterious sequencer – it always plays one extra note”

#220346
Jan 10, 2012 at 8:24pm

could you post the final version here, please?

#220347
Jan 10, 2012 at 9:09pm

Sure … just been adding a scaler too for output. Not very elegant but it does the job. Rehearsal ahoy!

– Pasted Max Patch, click to expand. –
#220348

You must be logged in to reply to this topic.