Forums > MaxMSP

matrixctl pattr interpolation cosmetics

July 21, 2006 | 9:50 pm

I just tried to use a pict with masking for matrixctrl. When interpolating
the settings with pattr I get a lot of noise in the redrawing of the object.
Test patch below, png file attached (I hope it sticks). Also dialmode and
dialtracking are missing from the docs.

I’m using winmax 4.5.7

best, -thijs

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 380 181 50 9109513 autopattr;
#X prestore pattern 72 0 0 0 0 0 1 0 0 2 0 1 0 0 1 1 0 1 2 0 2 0 0 2 1 0 2 2
0 3 0 0 3 1 0 3 2 0 4 0 0 4;
#X prestore pattern 72 40 1 0 4 2 0 5 0 0 5 1 0 5 2 0 6 0 0 6 1 0 6 2 0 7 0
0 7 1 0 7 2 0;
#P objectname u672000002;
#P flonum 442 124 35 9 1. 2. 3 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 463 88 14 9109513 2;
#P message 445 89 14 9109513 1;
#P message 373 109 50 9109513 store 2;
#P message 373 89 50 9109513 store 1;
#P newex 387 148 58 9109513 pattrstorage;
#X client_rect 0 0 640 240;
#X storage_rect 0 0 640 240;
#P objectname u967000001;
#P user matrixctrl 179 148 131 58 seq01_mask.png MatrixDefaultBkgnd.pct 131
58 16 16 8 3 16 16 0 0 112 2 2560 0;
#P objectname pattern;
#P connect 6 0 1 0;
#P connect 5 0 1 0;
#P connect 4 0 1 0;
#P connect 2 0 1 0;
#P connect 3 0 1 0;
#P window clipboard copycount 8;


July 21, 2006 | 11:32 pm

Continuing my matrixctrl experiments, I came across more drawing problems.
Basically I like to have the matrixctrl interface transparent (invisible
background) and have lcd behind it animating a timeline. (yes I’m working on
a step sequencer ;-) ) The problem is, putting other updating graphics
behind matrixctrl is causing glitches.

My question… is this something to be fixed or am I better off remaking the
interface all-in-one using sketch or lcd. What’s currently the most cpu
efficient way to do custom ui design in max/jitter which includes
opacity/alpha layering? Thanks.

-thijs

On 7/21/06, Thijs Koerselman

wrote:
>
> I just tried to use a pict with masking for matrixctrl. When interpolating
> the settings with pattr I get a lot of noise in the redrawing of the object.
> Test patch below, png file attached (I hope it sticks). Also dialmode and
> dialtracking are missing from the docs.
>
> I’m using winmax 4.5.7
>
> best, -thijs
>
> #P window setfont "Sans Serif" 9.;
> #P window linecount 1;
> #P newex 380 181 50 9109513 autopattr;
> #X prestore pattern 72 0 0 0 0 0 1 0 0 2 0 1 0 0 1 1 0 1 2 0 2 0 0 2 1 0 2
> 2 0 3 0 0 3 1 0 3 2 0 4 0 0 4;
> #X prestore pattern 72 40 1 0 4 2 0 5 0 0 5 1 0 5 2 0 6 0 0 6 1 0 6 2 0 7
> 0 0 7 1 0 7 2 0;
> #P objectname u672000002;
> #P flonum 442 124 35 9 1. 2. 3 139 0 0 0 221 221 221 222 222 222 0 0 0;
> #P message 463 88 14 9109513 2;
> #P message 445 89 14 9109513 1;
> #P message 373 109 50 9109513 store 2;
> #P message 373 89 50 9109513 store 1;
> #P newex 387 148 58 9109513 pattrstorage;
> #X client_rect 0 0 640 240;
> #X storage_rect 0 0 640 240;
> #P objectname u967000001;
> #P user matrixctrl 179 148 131 58 seq01_mask.png MatrixDefaultBkgnd.pct131 58 16 16 8 3 16 16 0 0 112 2 2560 0;
> #P objectname pattern;
> #P connect 6 0 1 0;
> #P connect 5 0 1 0;
> #P connect 4 0 1 0;
> #P connect 2 0 1 0;
> #P connect 3 0 1 0;
> #P window clipboard copycount 8;
>
>
>
>


Viewing 2 posts - 1 through 2 (of 2 total)