Forums > MaxMSP

Max 4 Live 6.1.5 Crashing on Mavericks

November 18, 2013 | 1:20 am

It’s funny because I managed to build a fairly complex patch over the last week yet in the last couple days it’s been harder and harder to do anything without it crashing. The patch plays fine in Live but opening the Max GUI causes a crash every time now within seconds of the main window opening. Some select details from the crash report…

Process: Max [708]
Path: /Applications/Max 6.1/Max.app/Contents/MacOS/Max
Identifier: com.cycling74.Max
Version: 6.1.5 [2117171] (6.1.5)
Code Type: X86-64 (Native)
Parent Process: Live [534]
Responsible: Live [534]
User ID: 501

Date/Time: 2013-11-18 09:05:01.850 +0000
OS Version: Mac OS X 10.9 (13A603)
Report Version: 11

Crashed Thread: 10

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: EXC_I386_GPFLT

Thread 10 Crashed:
0 com.cycling74.MaxAudioAPI 0x000000010a370d49 messagebuffer_readmessage + 24
1 com.cycling74.MaxAudioAPI 0x000000010a370ecc messagebuffer_read + 157
2 com.cycling74.MaxAudioAPI 0x000000010a374e95 plugrunner_sendmessageevents + 307
3 com.cycling74.MaxAudioAPI 0x000000010a37543d plugrunner_servicescheduler + 349
4 com.cycling74.MaxAudioAPI 0x000000010a37595d plugrunner_process + 152
5 com.cycling74.MaxAudioAPI 0x000000010a374bf9 plugrunner_devicethreadfun + 93
6 com.cycling74.Max 0x000000010007036b systhread_threadproc + 69
7 libsystem_pthread.dylib 0x00007fff9a02e899 _pthread_body + 138
8 libsystem_pthread.dylib 0x00007fff9a02e72a _pthread_start + 137
9 libsystem_pthread.dylib 0x00007fff9a032fc9 thread_start + 13

Thread 10 crashed with X86 Thread State (64-bit):
rax: 0x3f1065dd00000c17 rbx: 0x000000010f67a1d8 rcx: 0x0000000105e76000 rdx: 0x000000011853adc0
rdi: 0x000000010f67a1d8 rsi: 0x000000011853ad60 rbp: 0x000000011853ad40 rsp: 0x000000011853ad10
r8: 0×0000000000000040 r9: 0x000000011853ad00 r10: 0x00007fff9a4b49bd r11: 0x0000000000201d00
r12: 0×0000000000000001 r13: 0x000000011853adc0 r14: 0x0000000105e76000 r15: 0×0000000000000000
rip: 0x000000010a370d49 rfl: 0×0000000000010202 cr2: 0x0000000118539ee0

Logical CPU: 0
Error Code: 0×00000000
Trap Number: 13

…Everytime now it’s the same callstack with the crash on the `messagebuffer_readmessage` function. Hope this helps. I’m on a Macbook Pro Retina 15"


November 20, 2013 | 1:01 am

FYI I think this was Jitter related. Another patch I had in the Live project must have had Jitter components as I was seeing Jitter messages on the console. I created a new project with just my patch in it and all seems fine again.


Viewing 2 posts - 1 through 2 (of 2 total)