Forums > MaxMSP

Max 5.1.8 doesn't open Max 4 patches

April 18, 2011 | 7:09 am

(Mac Book Pro 2.5GHz, OS 10.6.7)

I have updated to max 5.1.8 and immediately could no longer open older (Max 4) patches. I read about this problem and the proposed solution on this forum – trashed Max 5 preferences and Max 5 application, resinstalled all and yet did not solve the problem,

Anyone had this problem?
thanks,
Miroslav


April 18, 2011 | 12:01 pm

If you want I can see if the same result appears on my Mac. I often open max 4 patches in Max5.


April 18, 2011 | 5:19 pm

Yes, best to post a simple example patch so we can find the issue.

-Ben


April 18, 2011 | 11:29 pm

Thanks a lot to both of you. I have posted one Max 4 patch.

Miroslav


April 18, 2011 | 11:36 pm

This loads "fine" here. By "fine", I mean it loads but complains that there are many externals missing.

If you are having problems with patches that contain third party externs, please contact those developers. Perhaps they have updated their externs to be compatible with Max 5.

If you have any patches that have problems with Cycling ’74 externals or content, please let us know and we can take it from there.

-Ben


April 20, 2011 | 6:08 am

Dear Ben,

thanks for this. It seems that the crash is related to another crash (I have posted at the same time) in Max 5; what happens is when I open a patch the patch is ‘blank’.

I have attached:

1. The patch that opens ‘blank’
2. The only external needed for the patch

NOTE: I have never had this problem before- it appeared this week when I updated to Max 5.1.8.

The header of the crash report is below.

Thanks a lot.

Miroslav

************

Process: MaxMSP [1471]
Path: /Applications/Max5/MaxMSP.app/Contents/MacOS/MaxMSP
Identifier: com.cycling74.MaxMSP
Version: 5.1.8 (45300) (5.1.8)
Code Type: X86 (Native)
Parent Process: launchd [135]

Date/Time: 2011-04-20 06:56:14.446 +0100
OS Version: Mac OS X 10.6.7 (10J869)
Report Version: 6

Interval Since Last Report: 319018 sec
Crashes Since Last Report: 78
Per-App Interval Since Last Report: 33836 sec
Per-App Crashes Since Last Report: 60
Anonymous UUID: 1E698A6A-3F04-4285-8559-70CC11EB29FE

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000013c1b000
Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Thread 0 Crashed: Dispatch queue: com.apple.main-thread
0 com.cycling74.MaxMSP 0×00381993 juce::LowLevelGraphicsSoftwareRenderer::clippedFillRectWithColour(juce::Rectangle const&, int, int, int, int, juce::Colour const&, bool) + 339
1 com.cycling74.MaxMSP 0x00381c56 juce::LowLevelGraphicsSoftwareRenderer::fillRectWithColour(int, int, int, int, juce::Colour const&, bool) + 118
2 com.cycling74.MaxMSP 0x00320e11 juce::Graphics::fillAll(juce::Colour const&) const + 107
3 com.cycling74.MaxMSP 0×00198241 MaxTopLevelWindow::paint(juce::Graphics&) + 153
4 com.cycling74.MaxMSP 0x002f82b4 juce::Component::paintEntireComponent(juce::Graphics&) + 684
5 com.cycling74.MaxMSP 0x00390b30 juce::ComponentPeer::handlePaint(juce::LowLevelGraphicsContext&) + 48
6 com.cycling74.MaxMSP 0x002dacba juce::HIViewComponentPeer::RepaintManager::paint(CGContext*, int, int, int, int) + 862
7 com.cycling74.MaxMSP 0x002db1bf juce::HIViewComponentPeer::hiViewDraw(OpaqueEventRef*) + 619
8 com.cycling74.MaxMSP 0x002db3b3 juce::HIViewComponentPeer::hiViewEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 425
9 com.apple.HIToolbox 0x91c4dc2f DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1567
10 com.apple.HIToolbox 0x91c4cef6 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 411
11 com.apple.HIToolbox 0x91c4cd55 SendEventToEventTargetWithOptions + 58
12 com.apple.HIToolbox 0x91c74f25 HIView::SendDraw(short, OpaqueGrafPtr*, __HIShape const*, CGContext*) + 475
13 com.apple.HIToolbox 0x91c74879 HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 713
14 com.apple.HIToolbox 0x91c74aec HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1340
15 com.apple.HIToolbox 0x91c74aec HIView::RecursiveDrawComposited(__HIShape const*, unsigned long, HIView*, CGContext*, unsigned char, float) + 1340
16 com.apple.HIToolbox 0x91c7389f HIView::DrawComposited(short, OpaqueGrafPtr*, __HIShape const*, unsigned long, HIView*, CGContext*) + 873
17 com.apple.HIToolbox 0x91c734e5 HIView::Draw(short, OpaqueGrafPtr*, unsigned long) + 83
18 com.apple.HIToolbox 0x91c73435 HIView::Render(unsigned long, CGContext*) + 45
19 com.apple.HIToolbox 0x91c7c89c FlushWindowObject(WindowData*, void**, unsigned char) + 754
20 com.apple.HIToolbox 0x91c7c2b5 FlushAllBuffers(__CFRunLoopObserver*, unsigned long, void*) + 177
21 com.apple.CoreFoundation 0x920a4e02 __CFRunLoopDoObservers + 1186
22 com.apple.CoreFoundation 0×92060439 CFRunLoopRunSpecific + 409
23 com.apple.CoreFoundation 0×92060291 CFRunLoopRunInMode + 97
24 com.apple.HIToolbox 0x91c7ae04 RunCurrentEventLoopInMode + 392
25 com.apple.HIToolbox 0x91c7aaf5 ReceiveNextEventCommon + 158
26 com.apple.HIToolbox 0x91e03137 ReceiveNextEvent + 83
27 com.cycling74.MaxMSP 0x002d3846 juce::juce_dispatchNextMessageOnSystemQueue(bool, bool) + 554
28 com.cycling74.MaxMSP 0x002dd4cb juce::MessageManager::dispatchNextMessage(bool, bool*, bool) + 79
29 com.cycling74.MaxMSP 0x002dd58a juce::MessageManager::runDispatchLoop() + 42
30 com.cycling74.MaxMSP 0x002dbee5 juce::JUCEApplication::main(juce::String&, juce::JUCEApplication*) + 605
31 com.cycling74.MaxMSP 0x002dbfbf juce::JUCEApplication::main(int, char**, juce::JUCEApplication*) + 125
32 com.cycling74.MaxMSP 0x001e5126 main + 76
33 com.cycling74.MaxMSP 0x00005d7e _start + 216
34 com.cycling74.MaxMSP 0x00005ca5 start + 41

Thread 1: Dispatch queue: com.apple.libdispatch-manager
0 libSystem.B.dylib 0x9607f922 kevent + 10
1 libSystem.B.dylib 0x9608003c _dispatch_mgr_invoke + 215
2 libSystem.B.dylib 0x9607f4f9 _dispatch_queue_invoke + 163
3 libSystem.B.dylib 0x9607f29e _dispatch_worker_thread2 + 240
4 libSystem.B.dylib 0x9607ed21 _pthread_wqthread + 390
5 libSystem.B.dylib 0x9607eb66 start_wqthread + 30
etc….

Attachments:
  1. msbakers.mxo.zip

April 20, 2011 | 7:12 am

Just tried your patch which loads fine. Same os, same max version. One thing however, it is discouraged to use the same name for a patch, and an external.


April 20, 2011 | 11:13 pm

HI jvkr,

thanks a lot. This was very helpful as now I am sure that there is something weird going on in my computer. I had been running the same patches without any problems for a year until I updated to Max 5.1.8. Something very strange must have happened at that moment.

I cannot open the patches and have no idea how to fix this.

Best,
M


April 20, 2011 | 11:20 pm

Hi M,

I’m going to take a wild guess and say that you have recently migrated from another machine or to a new OS?

This is a bit of a shot in the dark, but lets give it a try:

1. go to Applications/Font Book
2. select all
3. run ‘verify’
4. ‘remove’ any fonts that are diagnosed as bad

Let me know how this goes for you,
-Ben


April 21, 2011 | 6:06 am

Dear Ben,

FANTASTIC! It worked!
I ‘validated’ all fonts and three of those were found as bad fonts (‘x’ ). I removed them and everything started working as before.
I didn’t move to another computer and did not reinstall the OS. The two things I did were:

Regular Apple security update and updating to Max 5.1.8.
BIIIG THANK YOU!

Miroslav


April 21, 2011 | 3:36 pm

Miroslav, great! Glad we found the culprit.

For anyone else who has this problem, there is an issue when Max looks for a font that has conflicts or has been corrupted. This problem has just started popping up since 10.6.7 or so, and it appears to be a problem with how fonts get copied over after an OS update or system migration. If you do a web search, you can see that there are other applications that seem to be affected similarly.

-Ben


Viewing 11 posts - 1 through 11 (of 11 total)