Forums > MaxMSP

max 5 new patcher preferences, grid and more


f.e
April 26, 2008 | 11:20 am

Hi,

Let’s be constructive.

Is it possible not to have to say how we want our new patches to be
again and again ? I found some workarounds to work with max 5
(background color, font stuff, etc.) but it’s forgotten as soon as i
leave the current patch… How to set our default background color (edit
and presentation mode) and others new patcher preferences ?

In the same matter, how do we set the default palette size ?

Also, about "snap to grid", something kills me : it "snaps" when you
move, not when you resize objects. Even impossible, when you’ve resized,
to resize again to manually match the grid.

Last but not least, i’ve tried as said to edit shortcuts in the
maxinterface.json. I set "show connections" to "shift+L", but it only
works with "ctrl+shift+L"…

Best

f.e


f.e chanfrault | aka | personal computer music
>>>>>>> http://www.personal-computer-music.com
>>>>>>> |sublime music for a desperate people|


April 26, 2008 | 11:43 am

f.e wrote:
> How to set our default background color (edit and presentation mode)
> and others new patcher preferences ?
Options -> Object Defaults

BTW, did you find a cool font that looks like anti-aliasing was off ?



mdk
April 26, 2008 | 12:40 pm

Quote: f.e wrote on Sat, 26 April 2008 13:20
—————————————————-

> Last but not least, i’ve tried as said to edit shortcuts in the
> maxinterface.json. I set "show connections" to "shift+L", but it only
> works with "ctrl+shift+L"…
—————————————————-

I believe a capital letter signifies CTRL in the shortcuts.

try shift+l


April 26, 2008 | 12:52 pm

On 26 avr. 08, at 13:20, f.e wrote:
> Also, about "snap to grid", something kills me : it "snaps" when
> you move, not when you resize objects. Even impossible, when you’ve
> resized, to resize again to manually match the grid.

- select your object
- start resizing it
- on a mac, press the cmd key while continuing resizing (on Windows,
I guess it’s control ?)

Back to life ?

_M


April 26, 2008 | 2:04 pm

On 26 avr. 08, at 13:20, f.e wrote:
> Also, about "snap to grid", something kills me : it "snaps" when
> you move, not when you resize objects. Even impossible, when you’ve
> resized, to resize again to manually match the grid.

- select your object
- start resizing it
- on a mac, press the cmd key while continuing resizing (on Windows,
I guess it’s control ?)

Back to life ?

_M


April 26, 2008 | 3:06 pm

On 2008 Apr 26, at 6:43 AM, gusano wrote:
> f.e wrote:
>> How to set our default background color (edit and presentation
>> mode) and others new patcher preferences ?
> Options -> Object Defaults
>
> BTW, did you find a cool font that looks like anti-aliasing was off ?

Hi. I personally am using Verdana. At a typical patching-size I find
this font looks clearer than Arial.

best,
Tim
____________________________________
Tap.Tools – Objects for Max, MSP, and Jitter

http://electrotap.com/taptoolsmax/



mdk
April 26, 2008 | 3:13 pm

im a fan of gnome’s BitStream Vera

http://www.gnome.org/fonts/


April 26, 2008 | 6:22 pm

On Apr 26, 2008, at 4:20 AM, f.e wrote:
> Is it possible not to have to say how we want our new patches to be
> again and again ? I found some workarounds to work with max 5
> (background color, font stuff, etc.) but it’s forgotten as soon as i
> leave the current patch… How to set our default background color
> (edit and presentation mode) and others new patcher preferences ?

Um… Object Defaults? (Am I misunderstanding the question?)

You can even save different sets of defaults with the save feature.

> In the same matter, how do we set the default palette size ?

It will remember the last size you left it.

> Also, about "snap to grid", something kills me : it "snaps" when you
> move, not when you resize objects. Even impossible, when you’ve
> resized, to resize again to manually match the grid.

Command-resize.

> Last but not least, i’ve tried as said to edit shortcuts in the
> maxinterface.json. I set "show connections" to "shift+L", but it
> only works with "ctrl+shift+L"…

Command (Mac) or Control (Win) is implied in all the menu shortcuts, I
think.

Chris Muir
cbm@well.com

http://www.xfade.com



f.e
April 27, 2008 | 12:44 pm



f.e
April 27, 2008 | 12:53 pm



f.e
April 28, 2008 | 8:10 am

Chris,

Ctrl+click is cool, but it doesn’t help. In this attachment, you’ll find 2 boxes and a flonum where the flonum CAN’T be aligned in any ways.

best

f.e


April 28, 2008 | 8:49 am

On Apr 28, 2008, at 1:10 AM, f.e wrote:
> Ctrl+click is cool, but it doesn’t help. In this attachment, you’ll
> find 2 boxes and a flonum where the flonum CAN’T be aligned in any
> ways.

I don’t get what you are trying to do here. The flonum can’t be
aligned with what?

I selected all three objects and then did a Align Connections, and
everything straightened up, but I don’t think that that’s what you’re
after.

Chris Muir
cbm@well.com

http://www.xfade.com



f.e
April 28, 2008 | 9:00 am


April 28, 2008 | 9:39 am

On Apr 28, 2008, at 2:00 AM, f.e wrote:
> The flonum can’t be aligned to the right inlet of *~. Its patch cord
> isn’t aligned and can’t be.

You mean like this"

– Pasted Max Patch, click to expand. –

Chris Muir
cbm@well.com

http://www.xfade.com


April 29, 2008 | 8:07 am

f.e schrieb:
> The flonum can’t be aligned to the right inlet of *~. Its patch cord
> isn’t aligned and can’t be.

Do you mean that you’d prefer that the size of the *~ is aligned instead
of the position of the number when hitting Align Connections from the
Arrange menu?

If you want all objects aligned in size AND position, the patch cords
can’t, that’s obvious, but what is the problem with it?
(beside your aesthetical criterias against the overall look, we know
well already)

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com



f.e
April 29, 2008 | 11:08 am


April 29, 2008 | 5:35 pm

On Apr 29, 2008, at 4:08 AM, f.e wrote:
> I mean : we can align the patch cord using "Arrange / Align
> Connections" great feature, if i resize any object using ctrl+mouse,
> we lose the alignment grid and we have to redo "Align Connections"
> again.
>
> I hope what i say makes sense.
>
> Resize the *~ with ctrl+mouse (which is supposed to resize according
> to the grid), move the flonum, connect it, its cord won’t be
> aligned. Do "align connections", it will be. Resize the *~, you’ll
> never found the good position again…

I still don’t get what problem you’re seeing. These cases all work for
me:

– Pasted Max Patch, click to expand. –

Chris Muir
cbm@well.com

http://www.xfade.com



waj
April 30, 2008 | 2:47 pm



f.e
May 1, 2008 | 10:32 am



Eli
May 2, 2008 | 2:34 am

Remember, you can also change the size of the grid. Default is 15×15, but I’ve found that 10×10 works well also.

As I make patches in Max 5 I always seem to have snap-to-grid on as I begin, but toward the end of the patch I turn it off when I need to squeeze stuff in and make minor graphical and sequential adjustments.

I think a good way to use the grid is to measure the length of the object box which will change depending on the font you’re using and set up the grid to be that size, so boxes fit snuggly.


May 2, 2008 | 6:30 am

> I’ll do another try : If i resize an object like *~, it should resize
> accordingly to the grid and the flonum i would like to connect to the
> 2nd inlet should be located on the grid as well, so the connection
> should be right. But it’s never happening and i have to do a "align
> connections" which doesn’t align things on the grid, but do some dark
> art mess in order to make things match. Means we’re always messing
> "good" grid alignment with "floating" alignment and when dozen objects
> are involved and you move one, you find yourself in a deep s..t
>
> I guess it’s still unclear, so nevermind :-)

You mean, inlets and outlets should be what snap to grid, instead of the box itself.

_
johan


May 2, 2008 | 8:15 am

f.e schrieb:
> Sorry Chris (and the others). I guess i failed to explain my problem…
>
> I’ll do another try : If i resize an object like *~, it should resize
> accordingly to the grid and the flonum i would like to connect to the
> 2nd inlet should be located on the grid as well, so the connection
> should be right. But it’s never happening and i have to do a "align
> connections" which doesn’t align things on the grid, but do some dark
> art mess in order to make things match. Means we’re always messing
> "good" grid alignment with "floating" alignment and when dozen objects
> are involved and you move one, you find yourself in a deep s..t
>
> I guess it’s still unclear, so nevermind :-)

The only solution is to set your grid exactly to twice the distance from
in/oulet to the border of the object…
(would only work with the same font size for all objects…)

Or just give up on being rigrid… could be rewarding…

(I am not rigrid enough to test my thesis actually…)

And think about it, if nobody told you about a grid, you wouldn’t have a
problem…

It wasn’t different in Max 4 actually, you can’t align right and left
side to the same grid and expect the cords to be straight, unless your
grid is exactly twice the distance between cord and border of the
object. Your Max 4 grid had to be much smaller than a Max 5 grid…

The main problem seems, that the distance from in/oulet is linked to the
roundness, maybe you can convince David Z. to make it always the same…
(To allow rigrid patching with object boxes and numbers at the same time
f.e…)

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com



f.e
May 2, 2008 | 10:18 am


May 2, 2008 | 6:28 pm


May 5, 2008 | 11:57 am

f.e schrieb:
> EXACTLY. So simply said.

So the request is to have an option to choose between objects snap to
grid or first/last in/outlets snap to grid…

Seems reasonable, don’t know if cycling is still listening to this thread…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com


May 5, 2008 | 5:06 pm

On May 5, 2008, at 4:57 AM, Stefan Tiedje wrote:
> So the request is to have an option to choose between objects snap
> to grid or first/last in/outlets snap to grid…

It does mean that the rule of evenly spacing the inlets and outlets
can no longer apply. Inlets and outlets would have to be right or left
justified.

If I was Cycling, I would put this pretty far down the priority list.

Chris Muir
cbm@well.com

http://www.xfade.com



kjg
May 5, 2008 | 6:14 pm

Quote: Chris Muir wrote on Mon, 05 May 2008 19:06

> If I was Cycling, I would put this pretty far down the priority list.

I would put it on the "projects for after retirement" list.



f.e
May 5, 2008 | 9:13 pm


May 5, 2008 | 9:22 pm

On 5 mai 08, at 23:13, f.e wrote:

> I understand this is a Cornelian problem. Nevertheless, it makes the
> grid pretty useless, indeed. Disableing / ableing the grid in order
> to align manually some objects with others that were aligned
> automatically makes no sense. At the end, your patch doesn’t follow
> any rule (or any real grid should i say), and you often have to drag
> a bunch of objects away to then drag them back to be able to align
> them again with another bunch of objects which were aligned before
> etc.

Grid and Snap to Grid are also useful to position objects for
presentation mode where there’s even not visible connections.

ej


May 5, 2008 | 9:30 pm

After working pretty intensely with Max 5 for the last two weeks, I am
very happy with the grid mode. I’ve set the grid to 5 pixels, which
allows quite a bit of flexibility, while still obviously maintaining a
grid. I’ve never had to turn the grid off.

I have noticed that imported patcher’s objects (Max 4 patches) aren’t
on the grid, and I have to use the inspector to manually change their
location. In other words, if they appear at horizontal 72, the grid
will align them at 72 + 5, 72 + 10, etc.

The only problem I’ve had is using objects that may have multiple
outlets (i.e. gate 12) – in such cases, I can’t seem to get the patch
cords to align perfectly with the objects below.

2008/5/5 f.e

:
> Nevertheless, it makes the grid pretty useless, indeed.


May 5, 2008 | 9:39 pm

On May 5, 2008, at 2:13 PM, f.e wrote:
> I understand this is a Cornelian problem. Nevertheless, it makes the
> grid pretty useless, indeed. Disableing / ableing the grid in order
> to align manually some objects with others that were aligned
> automatically makes no sense. At the end, your patch doesn’t follow
> any rule (or any real grid should i say), and you often have to drag
> a bunch of objects away to then drag them back to be able to align
> them again with another bunch of objects which were aligned before
> etc.

There are really quite a few cool new patch organization methods in
Max 5:
- Presentation mode
- Align connections
- Scale space

The fact that the grid stuff does not live up to your expectations is
too bad, but why not get on with using the stuff that _is_ there?

To my way of thinking, things are _so_ much better in Max 5 than they
were in Max 4, that I’m happy to use Max 5 for a long while before I
start complaining about all the stuff I want to see in Max 6.

-C

Chris Muir
cbm@well.com

http://www.xfade.com



f.e
May 5, 2008 | 9:58 pm


May 7, 2008 | 10:05 am

Chris Muir schrieb:
> There are really quite a few cool new patch organization methods in Max 5:

Yes, thanks, there is simply no need to be rigrid…
I don’t see any aesthetical advantage of using a grid anyway. cmd-y is
all I need. And in presentation mode a grid might be useful enough…

A patch is a patch is a patch… To make it look nice, we have plenty of
options.
We can even get back roundless number boxes and messages:
(Will be difficult if you set a grid though… ;-)

– Pasted Max Patch, click to expand. –


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com



f.e
May 7, 2008 | 10:32 am


May 7, 2008 | 4:14 pm

On May 7, 2008, at 3:05 AM, Stefan Tiedje wrote:
> We can even get back roundless number boxes and messages:

Good one.

Chris Muir
cbm@well.com

http://www.xfade.com


Viewing 35 posts - 1 through 35 (of 35 total)