Max 5 vs. Max 4.x

Mar 3, 2008 at 8:35am

Max 5 vs. Max 4.x

hi all,

i got a question, and the answer is not in the faq (well, i didn’t see it).
i’m currently working on a Max application i’m sharing with some partners.
what if i migrate to Max 5 for this development and my partners don’t ?
will they be able to open patchs made with Max 5 under Max 4.x ?
i guess not, that’s also a way to force people uprading to a new version…
but it would be nice to have a “keep Max 4 compatibility” checkbox when
saving a patch with Max 5…

cheers

g.

#36155
Mar 3, 2008 at 9:01am

On 3 Mar 2008, at 08:35, Guillaume Evrard wrote:

> will they be able to open patchs made with Max 5 under Max 4.x ?

Nope: see “Old and New” in http://www.cycling74.com/story/
2007/9/28/105551/882 .

– N.

nick rothwell — composition, systems, performance — http://
http://www.cassiel.com

#123862
Mar 3, 2008 at 9:11am

On Mar 3, 2008, at 12:35 AM, Guillaume Evrard wrote:
> i got a question, and the answer is not in the faq (well, i didn’t
> see it).
> i’m currently working on a Max application i’m sharing with some
> partners.
> what if i migrate to Max 5 for this development and my partners
> don’t ?
> will they be able to open patchs made with Max 5 under Max 4.x ?
> i guess not, that’s also a way to force people uprading to a new
> version…
> but it would be nice to have a “keep Max 4 compatibility” checkbox
> when saving a patch with Max 5…

I think this is in the FAQ, or at least in one of David Zicarelli’s
articles, but the short answer is that there is no compatibility in
that direction. While it would be nice, there are so many new features
in Max 5 that wouldn’t map well to Max 4, as well as a new basic
architecture for Max 5 patchers, that it was deemed not worth the huge
effort.

Chris Muir
cbm@well.com

#123863

You must be logged in to reply to this topic.