Forums > MaxMSP

Max 6.1.2 Released

April 9, 2013 | 8:06 pm

We are happy to announce the hotfix release of Max 6.1.2. The primary impetus for this update was to fix saving to non-boot drive locations on Windows, although there are some other important fixes as well. Please take a look at the fixed bugs list below.

You can download it here:

http://cycling74.com/downloads/

Enjoy!
-Ben

Fixed Bugs:
• Gen: performance improvements when there are multiple Gen patchers
• Help files: old ‘.help’ files now open in Max 6.1
• jit.gl.gridshape: fixed crash in color setter with less than 4 args
• jit.phy.ghost: fix for crash when re-instantiating
• jit.window: misc fixes for @shared usage
• jit.window: fixed crash on save in Max For Live context
• Keyserver: Max 6.1 Keyserver FAT/x64 support
• Max Ref: tags are properly rendered when illustration is text
• mxj: fixed crash when loading amxd using mxj
• oscbank~: works on Windows x64
• pictslider: fixed issue with mode attribute
• Projects: fix opening Windows zip/maxzip files containing folders on OSX
• Retina display: patches are rendered correctly across displays
• saving: fix for saving to location other than boot drive
• umenu: native text rendering with windows now works
• vst~: fix for param output from UI interaction
• waveform~: offset attribute no longer produces inf/nan when the buffer is not ready



ak
April 11, 2013 | 1:33 am

• no pictures in MSP tutorials (maybe in others) [mbp,10.7.5, clean install]


April 11, 2013 | 8:45 am

i can totally reproduce here (mbp 10.6.8, supposedly clean install too)


April 11, 2013 | 4:05 pm

I can repro too. I’ll take a closer look.

Thanks,
-Ben


April 12, 2013 | 1:26 am

Thanks for the update!
When will improvements to vst~ in Windows occur? vst~ seems to dislike [crash on] loading samples and maintaining threads…32 and 64 bit


April 12, 2013 | 1:56 am

32bit, there are some minor improvements on the way, though I don’t know if they will address your specific issue. If you haven’t already, I would recommend filling out a bug report with any information you have on the behavior:

http://cycling74.com/max6-bug-form/

Thanks,
-Ben


April 13, 2013 | 5:00 pm

Out of interest, has that bug in Coll been resolved yet? I posted about it 5 months ago here..

http://cycling74.com/forums/topic.php?id=43302


April 16, 2013 | 3:51 pm

Hi , the obj pictslider don’t recognize the background and knob picture files. The images are in the right folder and in the right place inside the project folders, and the project itself comes from the mac version, where I’ve created the project and everything is working well.
The affected application is MaxMSP 6.1.2 PC version 32 bit (I don’t know the 64bit version). The same problem apperared in the 6.1 version too.
Version 6.0 is ok
Best regard


April 16, 2013 | 5:11 pm

keepsound, can you send a very simple project that shows this behavior to support at cycling 74 dot com? We would be happy to take a closer look.

Thanks,
-Ben


April 17, 2013 | 7:34 am

Yes, ofcourse, but I have to send you the entire project folder. At what mail can I send? If I post the compressed maxpat as text, you can’t load the pictures files for the pictslider obj…


April 17, 2013 | 8:38 am

Ben, I’ve send the project to your facebook account


April 18, 2013 | 2:42 pm

pictctrl and fpic aren’t load after update…


April 18, 2013 | 4:16 pm

Hi Snaper,

We are aware of some issues with the PICT image file format on Windows 32-bit, where they should work. PICT is not supported in 64-bit versions of Max 6.1+ on either platform.

If you are experiencing something else, please head over to support at cycling 74 dot com with a simple example and steps to reproduce what you are seeing.

Thanks!
-Ben


April 18, 2013 | 7:02 pm

Hi , today I’va converted the .pict files in .jpg, and this works fine, so that’s the solution, but there’s to use an external pictures editor (I’m using an old GraphicConverter on my Mac, and then import the new images in the PC Media folder. What’s strange, is that this behavior happens only in the (32bit) 6.1.2 PC version of MaxMSP, and not in the same version in the 32 bit application on the win PC.
That’s all, best wishes!
Italo


April 21, 2013 | 11:39 pm

Another bug (?) today with vst obj, MaxMSP 6.1.2. in 64 bit mode on Mac 10.6.8.
The same patch is working well in the 32 bit mode.
Bug is regarding the vst obj, loading a Waveshell (vst 8.0) plug in. In the max window appears WaveShell-VST 8.0.vst: no format VST exists
That happens only for the Waveshell VST plugs, the normal VSTs (not in 64 bit) are correctly loaded.
Any idea to solve this problem?
Thanx
Italo

– Pasted Max Patch, click to expand. –

April 22, 2013 | 4:28 pm

Hi Italo.

I don’t believe Waves 8.0 is 64-bit compatible. I do see that Waves 9 is now out and features 64 bit compatibility:

http://www.wavesupport.net/content.aspx?id=4380

Best,
-Ben


April 22, 2013 | 8:10 pm

ok, thanks


April 25, 2013 | 6:01 am

Thank you Ben. I’m still downloading that


Viewing 18 posts - 1 through 18 (of 18 total)