Max 6.1.2 Released

Apr 9, 2013 at 8:06pm

Max 6.1.2 Released

We are happy to announce the hotfix release of Max 6.1.2. The primary impetus for this update was to fix saving to non-boot drive locations on Windows, although there are some other important fixes as well. Please take a look at the fixed bugs list below.

You can download it here:

http://cycling74.com/downloads/

Enjoy!
-Ben

Fixed Bugs:
β€’ Gen: performance improvements when there are multiple Gen patchers
β€’ Help files: old ‘.help’ files now open in Max 6.1
β€’ jit.gl.gridshape: fixed crash in color setter with less than 4 args
β€’ jit.phy.ghost: fix for crash when re-instantiating
β€’ jit.window: misc fixes for @shared usage
β€’ jit.window: fixed crash on save in Max For Live context
β€’ Keyserver: Max 6.1 Keyserver FAT/x64 support
β€’ Max Ref: tags are properly rendered when illustration is text
β€’ mxj: fixed crash when loading amxd using mxj
β€’ oscbank~: works on Windows x64
β€’ pictslider: fixed issue with mode attribute
β€’ Projects: fix opening Windows zip/maxzip files containing folders on OSX
β€’ Retina display: patches are rendered correctly across displays
β€’ saving: fix for saving to location other than boot drive
β€’ umenu: native text rendering with windows now works
β€’ vst~: fix for param output from UI interaction
β€’ waveform~: offset attribute no longer produces inf/nan when the buffer is not ready

#67625
Apr 11, 2013 at 1:33am

β€’ no pictures in MSP tutorials (maybe in others) [mbp,10.7.5, clean install]

#243346
Apr 11, 2013 at 8:45am

i can totally reproduce here (mbp 10.6.8, supposedly clean install too)

#243347
Apr 11, 2013 at 4:05pm

I can repro too. I’ll take a closer look.

Thanks,
-Ben

#243348
Apr 12, 2013 at 1:26am

Thanks for the update!
When will improvements to vst~ in Windows occur? vst~ seems to dislike [crash on] loading samples and maintaining threads…32 and 64 bit

#243349
Apr 12, 2013 at 1:56am

32bit, there are some minor improvements on the way, though I don’t know if they will address your specific issue. If you haven’t already, I would recommend filling out a bug report with any information you have on the behavior:

http://cycling74.com/max6-bug-form/

Thanks,
-Ben

#243350
Apr 13, 2013 at 5:00pm

Out of interest, has that bug in Coll been resolved yet? I posted about it 5 months ago here..

http://cycling74.com/forums/topic.php?id=43302

#243351
Apr 16, 2013 at 3:51pm

Hi , the obj pictslider don’t recognize the background and knob picture files. The images are in the right folder and in the right place inside the project folders, and the project itself comes from the mac version, where I’ve created the project and everything is working well.
The affected application is MaxMSP 6.1.2 PC version 32 bit (I don’t know the 64bit version). The same problem apperared in the 6.1 version too.
Version 6.0 is ok
Best regard

#243352
Apr 16, 2013 at 5:11pm

keepsound, can you send a very simple project that shows this behavior to support at cycling 74 dot com? We would be happy to take a closer look.

Thanks,
-Ben

#243353
Apr 17, 2013 at 7:34am

Yes, ofcourse, but I have to send you the entire project folder. At what mail can I send? If I post the compressed maxpat as text, you can’t load the pictures files for the pictslider obj…

#243354
Apr 17, 2013 at 8:38am

Ben, I’ve send the project to your facebook account

#243355
Apr 18, 2013 at 2:42pm

pictctrl and fpic aren’t load after update…

#243356
Apr 18, 2013 at 4:16pm

Hi Snaper,

We are aware of some issues with the PICT image file format on Windows 32-bit, where they should work. PICT is not supported in 64-bit versions of Max 6.1+ on either platform.

If you are experiencing something else, please head over to support at cycling 74 dot com with a simple example and steps to reproduce what you are seeing.

Thanks!
-Ben

#243357
Apr 18, 2013 at 7:02pm

Hi , today I’va converted the .pict files in .jpg, and this works fine, so that’s the solution, but there’s to use an external pictures editor (I’m using an old GraphicConverter on my Mac, and then import the new images in the PC Media folder. What’s strange, is that this behavior happens only in the (32bit) 6.1.2 PC version of MaxMSP, and not in the same version in the 32 bit application on the win PC.
That’s all, best wishes!
Italo

#243358
Apr 21, 2013 at 11:39pm

Another bug (?) today with vst obj, MaxMSP 6.1.2. in 64 bit mode on Mac 10.6.8.
The same patch is working well in the 32 bit mode.
Bug is regarding the vst obj, loading a Waveshell (vst 8.0) plug in. In the max window appears WaveShell-VST 8.0.vst: no format VST exists
That happens only for the Waveshell VST plugs, the normal VSTs (not in 64 bit) are correctly loaded.
Any idea to solve this problem?
Thanx
Italo

– Pasted Max Patch, click to expand. –
#243359
Apr 22, 2013 at 4:28pm

Hi Italo.

I don’t believe Waves 8.0 is 64-bit compatible. I do see that Waves 9 is now out and features 64 bit compatibility:

http://www.wavesupport.net/content.aspx?id=4380

Best,
-Ben

#243360
Apr 22, 2013 at 8:10pm

ok, thanks

#243361
Apr 25, 2013 at 6:01am

Thank you Ben. I’m still downloading that

#243362

You must be logged in to reply to this topic.