Max 6. Turning audio on wipes out external controllers

Oct 1, 2012 at 5:00pm

Max 6. Turning audio on wipes out external controllers

I have a large patch that works fine (at around 50-65%cpu) in Max 5. (OSX 10.8.2; Macbook Pro).
There’s a lot of audio running, including some VSTs and VSTis, and the whole thing is controlled by wii controllers via Osculator. (into max via [ctlin])
In max6, as long as audio is off, the controllers work fine, but as soon as I turn audio on, the controller inputs grind to a halt. There are little bursts of delayed data from time to time.
Is there anything in the settings that might make a big difference to this?

My dsp settings are:
I/O vector: 512
Signal vector: 512
Scheduler in Overdrive and Audio Interrupt both on.
Vector optimization on.
Mixer crossfade off.

I’ve tried progressively lowering the vector sizes, and the sensor response improves – but the output of the VSTis gets progressively cracklier, until at a vector size of 32 it actually sounds like ring modulation on their output.
At 256, the sound output is ok, until I move one of the controllers, and then I get crackling (so I guess it’s something to do with data overload).
So 512 seems to be best for the sound, but useless for the wii controllers. (and, I suspect, the infra red controllers which I haven’t checked out yet – they come in on a usb midi box)

Any suggestions?

thanks

David

#64572
Oct 1, 2012 at 5:21pm

Try with Audio Interrupt off.

#233006
Oct 3, 2012 at 4:43pm

That did it. And there don’t seem to be any other problems as a result.

Thanks dtr

David

#233007

You must be logged in to reply to this topic.