Forums > MaxMSP

Max GUI freezes when adding a new object

July 14, 2011 | 8:09 pm

Hi,

Here is the problem:

1) add a new object on a Max patcher, using the ‘N’ key

2) type the name, then press Enter; alternatively, select the object if it auto-completes

3) most of the time, the GUI freezes for about 1 second before the object is added

It also occurs when changing an existing object into another.

Only happens on Windows 7 (not OSX)

Any way to avoid this?

Best,
Julien


July 14, 2011 | 9:46 pm

Hi Julien,

This is definitely not normal. Does this happen with any object, Max, MSP and Jitter objects? Is it persistent, or does it go away?

Each session, there will be a very brief delay the very first time that a Jitter object is created, but this will only happen once.

Other than that, I cannot reproduce on a win 7 box.

What computer model, graphics card and version of Max do you have running?

-Ben


July 14, 2011 | 10:07 pm

It happens with all objects and it is persistent.

Computer model: this is a new, custom desktop computer (Core i7 Sandy Bridge architecture)

Graphics: Saffire HD 5450 (ATI)

Max 5.1.8 (45300)

If it helps…


July 15, 2011 | 5:13 pm

Hmm, yeah, can’t repro here. Wonder if anyone else reading this has a Saffire HD 5450 card and can repro.

Do you have any processes running in the background that might be gumming up the works?

Sorry I can’t be of more help at the moment.

-Ben


July 15, 2011 | 7:55 pm

Thanks for your help anyway… I will not change the HD 5450 because it works with all other softwares. I had an Asus EN210 before and it was problematic (the Nvidia driver produces lots of DPC spikes currently) so I changed it for this Saffire.

For the processes I don’t know, this computer is quite optimized and works well. Even Max runs really normally, it’s only the patch edition which is sluggish. 34 processes are running in idle mode, none of which can be removed easily.

-j


July 15, 2011 | 8:01 pm

Hi Julien,

I’m not suggesting that you switch cards, I’m just am curious if this is where the issue is.

Do you notice any other GUI slowdowns in Max? The Filebrowser, menus, DSP Status window, etc?

-Ben


July 15, 2011 | 9:36 pm

no other slowdown so far

max itself is pretty slow to launch (compared to Reaper for example, and given the fact I have a SSD drive), but it’s really not a problem

-j


September 17, 2011 | 11:29 am

I’ve the same problem.
Windows 7 64bits, ATI Radeon 6950, intel core i7, max 5.1.9.

I’m using jitter, a complex patch.
And, after a moment, when i’m editing a lot of parameters (but not so much…) max freeze the windows.
I can follow my operation with my midi interface, and image sending to videoprojector still responding but the main screen (where is the patch) is freezing.
All other program works fine.

What happen ?


September 17, 2011 | 11:46 am

As you can see…
Chrome is working fine, my projection too (on the right), but max gui freeze.
And often crashes…

[attachment=171008,2633]

Attachments:
  1. maxcrash.jpg

Viewing 9 posts - 1 through 9 (of 9 total)