Max hangs when closing patch and dac~ is on

Apr 19, 2007 at 3:39pm

Max hangs when closing patch and dac~ is on

I’ve noticed a consistent pattern – if I close a patch containing a dac~ (or any dac~ like object), and the dac~ is ON, then Max will hang.

Is there any way to force clean close of the dac~ object when a patch is closed? Are there any other solutions to this issue?

I am using Max/MSP 4.6, Jitter 1.6, on a Thinkpad T60 with Windows XP.

#31474
Apr 19, 2007 at 8:56pm

I think thers closebang but Im at work right now so cant check.

#102456
Apr 20, 2007 at 9:50pm

Quote: gian.pablo@gmail.com wrote on Thu, 19 April 2007 17:39
—————————————————-
> I’ve noticed a consistent pattern – if I close a patch containing a dac~ (or any dac~ like object), and the dac~ is ON, then Max will hang.
>
> Is there any way to force clean close of the dac~ object when a patch is closed? Are there any other solutions to this issue?
>
> I am using Max/MSP 4.6, Jitter 1.6, on a Thinkpad T60 with Windows XP.
—————————————————-

Some MSP objects don’t shut down properly if they are disposed while DSP is running. It’s not dac~’s fault, it’s most likely the fault of some rogue object that does not follow proper deallocation procedure.

Try removing MSP objects from you patch until you can identify which one is causing the crash.

HtH — P.

#102457
Apr 22, 2007 at 3:48am

Got it, it’s fluidsynth~.

I’ve put in a closebang to shut down dac~ when closing patch, seems to work.

#102458
Apr 22, 2007 at 3:43pm

Quote: gian.pablo@gmail.com wrote on Sun, 22 April 2007 05:48
—————————————————-
> Got it, it’s fluidsynth~.
>
> I’ve put in a closebang to shut down dac~ when closing patch, seems to work.
—————————————————-

You should write to Norbert Schnell about the problem.

#102459

You must be logged in to reply to this topic.