Forums > MaxMSP

Max hangs when closing patch and dac~ is on

April 19, 2007 | 3:39 pm

I’ve noticed a consistent pattern – if I close a patch containing a dac~ (or any dac~ like object), and the dac~ is ON, then Max will hang.

Is there any way to force clean close of the dac~ object when a patch is closed? Are there any other solutions to this issue?

I am using Max/MSP 4.6, Jitter 1.6, on a Thinkpad T60 with Windows XP.


April 19, 2007 | 8:56 pm

I think thers closebang but Im at work right now so cant check.


April 20, 2007 | 9:50 pm

Quote: gian.pablo@gmail.com wrote on Thu, 19 April 2007 17:39
—————————————————-
> I’ve noticed a consistent pattern – if I close a patch containing a dac~ (or any dac~ like object), and the dac~ is ON, then Max will hang.
>
> Is there any way to force clean close of the dac~ object when a patch is closed? Are there any other solutions to this issue?
>
> I am using Max/MSP 4.6, Jitter 1.6, on a Thinkpad T60 with Windows XP.
—————————————————-

Some MSP objects don’t shut down properly if they are disposed while DSP is running. It’s not dac~’s fault, it’s most likely the fault of some rogue object that does not follow proper deallocation procedure.

Try removing MSP objects from you patch until you can identify which one is causing the crash.

HtH — P.


April 22, 2007 | 3:48 am

Got it, it’s fluidsynth~.

I’ve put in a closebang to shut down dac~ when closing patch, seems to work.


April 22, 2007 | 3:43 pm

Quote: gian.pablo@gmail.com wrote on Sun, 22 April 2007 05:48
—————————————————-
> Got it, it’s fluidsynth~.
>
> I’ve put in a closebang to shut down dac~ when closing patch, seems to work.
—————————————————-

You should write to Norbert Schnell about the problem.


Viewing 5 posts - 1 through 5 (of 5 total)