Max, Midi and Pro Tools

Dec 12, 2008 at 9:39am

Max, Midi and Pro Tools

I am trying to make a virtual controller to lay down controller change data on midi tracks in pro tools.

I have made my virtual interface – have the midi successfully leaving max, and being received by Ableton Live(to troubleshoot), but will not be received by pro tools.

Is this a glitch or bug or something? I have tried this using the from/to maxmsp ports (which Pro Tools sees just fine, though doesn’t receive data from), and also using the IAC driver, and alas – no love.

I just find it weird that I am able to get midi from max to Ableton just fine, but pro tools wont have it.

Any ideas out there?

Also – I can send notes from Pro Tools to max/ableton no problem. And obviously I have tried sending control change data, and midi notes during all tests.

Dec 12, 2008 at 10:07am

Really? Pro Tools not cooperating with other programs? My, that’s a
surprise! If you don’t have a list of reasons to s***-can Pro Tools, I say
start one, and add this to the top.

Beyond that, I have had the exact same problems–both with MIDI and with
audio signals–when other programs worked without a hitch (Live, Logic,
etc.) What OS are you running? And, what’s your MIDI configuration look


Dec 12, 2008 at 10:25am

Its not really much of a configuration: Not running through anykind of timepiece, or midi box. The midi is traveling through software only, either through max’s virtual midi port, or through IAC.

Running OS X leopard
Pro Tools 7.4.2
Max/MSP – 4.6
Ableton 6.02

Dec 12, 2008 at 4:51pm

Did you enable the input device in ProTools ?

(Setup>MIDI>Input Devices)

Dec 12, 2008 at 5:16pm

WHOA, maybe I am stupid – Ill have to check that when i get home – pretty sure I went throught all of that – see if my certification means anything ;p


Dec 14, 2008 at 11:26pm

Yah…. its all fine in there.

Mar 26, 2009 at 9:29pm

Acoostix –

Did you get this problem solved? I am also trying to route Max MIDI to ProTools. Let us know if you’ve found a solution!



You must be logged in to reply to this topic.