Forums > MaxMSP

Max occupying one processor on multicore WinXP Machine

May 15, 2008 | 11:36 am

I am using two Max/Jitter applications on a dual core WinXP computer.
When I start those Applications I experience accidental performance
problems. I could isolate the problem to the observation that sometimes
when I start only one of the applications one cpu is fully occupied.
this means that the task manager shows 50% at least plus the usual load.

To figure out what happens I opened this one patch in MaxRuntime and
could observe the same phenomenon. Then I could even reproduce this
behavior in Max. In the following I started to delete everything in my
open patch. Max still on 50% CPU.

I then sent the following messages to jitter:
parallel 0
glattribpush 1
glerrorcheck 0

then I played with the performance options. Still 50%

then I took some screenshots to prove that I am not dreaming.

Did anyone experience this problem before? Since Max/Jitter makes most
use of only one processor it may be the case that it is not always
obvious if this behavior occurs.

The patch is very complex and the problem is not always reproducable. Is
there anything I can do to isolate or avoid this?

MaxMsp 4.6.3, Jitter 1.6.3, WinXP, Dual2core 8500 Processor, Nvidia
8600GTS Graphic Card.

Thanks. John.


May 19, 2008 | 3:38 pm

For the sake of the archives I will answer my own question. This is a
windowsXP Multicore Processor Bug as discribed here:

http://support.microsoft.com/kb/896256/EN-US/

Thank you for following this thread.

John Dekron

John Dekron schrieb:
> I am using two Max/Jitter applications on a dual core WinXP computer.
> When I start those Applications I experience accidental performance
> problems. I could isolate the problem to the observation that sometimes
> when I start only one of the applications one cpu is fully occupied.
> this means that the task manager shows 50% at least plus the usual load.
>
> To figure out what happens I opened this one patch in MaxRuntime and
> could observe the same phenomenon. Then I could even reproduce this
> behavior in Max. In the following I started to delete everything in my
> open patch. Max still on 50% CPU.
>
> I then sent the following messages to jitter:
> parallel 0
> glattribpush 1
> glerrorcheck 0
>
> then I played with the performance options. Still 50%
>
> then I took some screenshots to prove that I am not dreaming.
>
> Did anyone experience this problem before? Since Max/Jitter makes most
> use of only one processor it may be the case that it is not always
> obvious if this behavior occurs.
>
> The patch is very complex and the problem is not always reproducable. Is
> there anything I can do to isolate or avoid this?
>
> MaxMsp 4.6.3, Jitter 1.6.3, WinXP, Dual2core 8500 Processor, Nvidia
> 8600GTS Graphic Card.
>
> Thanks. John.
>
>


Viewing 2 posts - 1 through 2 (of 2 total)