[max5] Fix Width and UI Object

May 2, 2008 at 10:44am

[max5] Fix Width and UI Object

#37466
May 3, 2008 at 9:05am

> 1. put some dials, knobs, buttons and toggles
> 2. select them and scale them with the new (great) scalable function
> 3. hit Command + J (or Control + J for xp)
>
> And all your beautifull GUI is scrambled.
> UI Objects go back to their default sizes !
> This wasn’t the case in max4 and IMHO shouldn’t be the case in 5.
>
> Select All + Fix Width -> Another habit we have to lose I guess…
>

—————————————————-

What should fix width do according to you to ui objects? In versions previous to 5 it didn’t do anything, that’s what you mean with habit?

_
johan

#129507
May 3, 2008 at 9:52am

#129508
May 3, 2008 at 10:16am

>Yes
>I’m used
>I’m used
>I’m used
>I’m used
>I’m used
>I’m used
>I’m used

The other day I started a calculation of how many connections in my brain will either become obsolete or have to be renewed, but after 245,469,478,123 I lost count. As a matter of fact, max appeared in my dreams, which hadn’t happen for more then 10 years. This points to switching to 5 being a dramatic crisis indeed. I figured that viewing 5 as something non-related to previous versions of max (it might as well come from a different company) makes it easier to accept it’s differentness. What appears as fixed reality is merely a shadow. This is not a piece of good advice, but simply my experience.

_
johan

#129509
May 3, 2008 at 10:49am

#129510
May 3, 2008 at 4:35pm

#129511
May 3, 2008 at 5:40pm

Quote: Chris Muir wrote on Sat, 03 May 2008 18:35
—————————————————-

> This can be edited to not float.

—————————————————-

How can I do that? Do I have to send a message starting with a semicolon? Can’t open the DSP-Status window as a normal patcher (as it was in 4)

thanks,

ole

#129512
May 3, 2008 at 5:51pm

Quote: oe7 wrote on Sat, 03 May 2008 19:40
—————————————————-

> How can I do that? Do I have to send a message starting with a semicolon? Can’t open the DSP-Status window as a normal patcher (as it was in 4)
>
> thanks,
>
> ole
—————————————————-

the message ; dsp wclose is not working, can someone reproduce that?

(as described in “Controlling MSP with Messages”)

#129513
May 3, 2008 at 5:53pm

Quote: oe7 wrote on Sat, 03 May 2008 19:51
—————————————————-
> Quote: oe7 wrote on Sat, 03 May 2008 19:40
> —————————————————-
>
> > How can I do that?

ctrl+click will give you the option to go to edit mode. There is already a toggle provided for making the window non-floating.

_
johan

#129514
May 3, 2008 at 6:14pm

#129515
May 3, 2008 at 6:36pm

#129516
May 3, 2008 at 7:12pm

On May 3, 2008, at 10:40 AM, Ole Schmidt wrote:
> How can I do that? Do I have to send a message starting with a
> semicolon? Can’t open the DSP-Status window as a normal patcher (as
> it was in 4)

Sure you can. On the Mac, it lives here: Cycling ’74/interfaces/DSP
Status.maxpat

Open it, unlock it, notice the two toggles with orange labels, one
labeled View, and one labeled NoFloat. View changes window size and
out of presentation view. NoFloat does just that.

-C

Chris Muir
cbm@well.com

http://www.xfade.com

#129517

You must be logged in to reply to this topic.