Forums > MaxMSP

Max5 launching very slowly

November 5, 2011 | 4:20 pm

Max 5 is taking around a minute and a half to launch (sometimes longer) the first time I launch it after starting up.

OS X 10.6.7
MacBook Pro 1.1
2.16 GHz
2GB RAM

This is much longer than it used to take.
A friend’s does the same thing only worse – and they have no external libraries included.

Does anyone what could be causing this and how it could be fixed.

Thanks


November 6, 2011 | 1:44 am

might be File Preferences paths taking a long time to load, if you’ve added a bunch. I’ve ran into the same problem…also I started to get lots of "Warning: You have multiple files with the same name…etc" messages in the Max window. Trashing the Max5 Preferences folder solved both of these. So unless you have some prefs you want to keep, you can try that and see what happens…when you relaunch Max it’ll create a new default Preferences folder. If you have new Prefs you want to save, you’ll have to figure out which of the files you should keep before trashing the rest.


November 6, 2011 | 11:48 pm

One issue I have seen that causes quite a lot of systems to slow down their startup is if they are trying to access a remote site (for update checking or authorization) and there’s a problem with DNS.

I’ve actually had this happen to me when opening the "Network" icon in the MIDI part of Audio/MIDI setup because the first entry in my DNS was a server to which my laptop was not connected at the time.

The problem is DNS queries are blocked out and typically take about 9 seconds before they time out. Since one doesn’t know they’re happening unless one is running something like LittleSnitch on a Mac or ZoneAlarm on Windows, it just looks like incredibly slow startup.

I’ve no idea whether this is what’s happening in the case described here but it’s worth crossing off the list.


November 7, 2011 | 8:13 am

seejayjames you are right.. i have the same problem too because i am
pervert and i use dark fonts.. so i must change and all the other objects..

the problem is getting worse in max 6 which in my computer launch sometimes after 2 or 3 minutes (!!!)when in max 5 takes about 30 sec.When i trash preferences folder takes 50 seconds to launch(max 6).

also in a period of 1 month testing max 6 i forced to trash this folder 3 times because max 6 could not launch at all!!

Cycling 74 please do something..


Viewing 4 posts - 1 through 4 (of 4 total)