Forums > MaxMSP

Max5 Standalone Problems

May 13, 2008 | 2:32 pm

I’m wondering if anyone has successfully run a Max 5 Windows standalone on a different machine with no trace of the Max Application or Runtime present?

I’ve made numerous standalone tests with and without jitter, all work fine on my machine (Windows XP pro on bootcamp) but won’t run on another machine without Max5 installed. Error "This application has failed to start because the application configuration is incorrect. Reinstalling the application may fix this problem"


May 13, 2008 | 3:40 pm

Hi,

Please read the section "Runtime Library Dependency" on this page:

http://www.cycling74.com/docs/max5/vignettes/core/standalone_platform_win.html

Hth,
Rob


May 13, 2008 | 7:59 pm

Every standalone application that I create with Max 5 that utilizes a jitter quicktime movie crashes when the movie is enabled.

I’ve attached an example that fails as a standalone application.

System specs:
MaxMSP 5.0.2 (34989)
MacBook Pro 2.4GHz
Mac OSX 10.5.2
4GB RAM


May 13, 2008 | 8:21 pm

Thank you,

For some reason I hadn’t read this part:

"To use a standalone on a computer that has not run the Max installer or the Max 5 installer you must first run the Microsoft Visual C++ 2008 Redistributable Package (x86)."

Though I had read in the ‘collective_guide’:

"Standalone applications, which are always platform-specific, can eliminate all external dependencies for others to run your patch."

Which is perhaps where the confusion arose.


May 14, 2008 | 9:50 am

Hi,
I did some investigation on making standalones on win, see:

http://www.cycling74.com/forums/index.php?t=rview&th=33373&rid=0

Falk


Viewing 5 posts - 1 through 5 (of 5 total)