Forums > MaxMSP

[Max5] zigzag~ bug report

August 21, 2008 | 7:23 pm

hi everybody

my patch always crashes since i’ve ported it to Max 5

look at this :

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P comment 43 254 224 9109513 (Windows XP Pro & Max OS X , both intel Core2Duo);
#P comment 66 235 94 9109513 but not on Max 5.0.4;
#P comment 52 217 161 9109513 seems to work under Max 4.6.3;
#P message 362 135 16 9109513 1.;
#P flonum 315 247 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 507 140 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 543 165 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 543 113 29 9109513 100;
#P newex 490 192 27 9109513 +~;
#P newex 490 216 29 9109513 saw~;
#P user ezdac~ 490 280 534 313 0;
#P newex 272 284 53 9109513 zigzag~;
#P message 272 217 163 9109513 0. 0. 0.5 70 1. 30 0.6 30 0. 70;
#P newex 272 189 34 9109513 gate 1;
#P toggle 272 120 37 0;
#P newex 362 70 45 9109513 loadbang;
#P newex 490 168 27 9109513 *~;
#P message 507 113 29 9109513 900;
#P fasten 2 0 3 0 367 116 277 116;
#P connect 3 0 4 0;
#P connect 4 0 5 0;
#P connect 5 0 6 0;
#P fasten 6 3 4 1 319 310 441 310 441 167 301 167;
#P fasten 14 0 13 0 367 199 320 199;
#P connect 13 0 6 1;
#P connect 2 0 14 0;
#P fasten 6 0 1 0 277 332 454 332 454 151 495 151;
#P connect 1 0 9 0;
#P connect 9 0 8 0;
#P connect 8 0 7 0;
#P fasten 2 0 0 0 367 100 512 100;
#P connect 0 0 12 0;
#P connect 12 0 1 1;
#P connect 11 0 9 1;
#P connect 8 0 7 1;
#P fasten 2 0 10 0 367 100 548 100;
#P connect 10 0 11 0;
#P window clipboard copycount 18;

it will work fine for a short, (or a long…) time but there is always a crash under Max5…

but it seems to be stable with this method :

#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P newex 345 44 45 9109513 loadbang;
#P window linecount 3;
#P comment 72 196 195 9109513 it seems to work under Max 4.6.3 & Max 5.0.4 with this method (the list isn’t sent each time);
#P window linecount 1;
#P message 362 135 16 9109513 1.;
#P flonum 315 247 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 507 140 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 543 165 35 9 0 0 0 139 0 0 0 221 221 221 222 222 222 0 0 0;
#P message 543 113 29 9109513 100;
#P newex 490 192 27 9109513 +~;
#P newex 490 216 29 9109513 saw~;
#P user ezdac~ 490 280 534 313 0;
#P newex 272 284 53 9109513 zigzag~;
#P message 294 220 163 9109513 0. 0. 0.5 70 1. 30 0.6 30 0. 70;
#P newex 272 189 34 9109513 gate 1;
#P toggle 272 120 37 0;
#P newex 345 67 27 9109513 t b b;
#P newex 490 168 27 9109513 *~;
#P message 507 113 29 9109513 900;
#P connect 10 0 11 0;
#P fasten 2 1 3 0 367 103 277 103;
#P fasten 2 1 14 0 367 110 367 110;
#P fasten 2 1 0 0 367 99 512 99;
#P fasten 2 1 10 0 367 99 548 99;
#P connect 8 0 7 0;
#P connect 8 0 7 1;
#P connect 11 0 9 1;
#P connect 12 0 1 1;
#P connect 0 0 12 0;
#P connect 9 0 8 0;
#P connect 1 0 9 0;
#P fasten 6 0 1 0 277 332 454 332 454 151 495 151;
#P connect 16 0 2 0;
#P connect 13 0 6 1;
#P fasten 14 0 13 0 367 199 320 199;
#P fasten 6 3 4 1 319 310 441 310 441 167 301 167;
#P connect 2 0 5 0;
#P connect 5 0 6 0;
#P connect 4 0 6 0;
#P connect 3 0 4 0;
#P window clipboard copycount 17;

sorry…

Antoine


August 21, 2008 | 9:10 pm

Hasn’t crashed for me on Mac OSX 10.4.11 in Max 5.04 for about 10 minutes now – how long do I have to wait?

-A


August 21, 2008 | 9:14 pm

it depends… sometimes about 30 seconds, sometimes 5 minutes
crash happens more quickly when I change parameters with mouse (flonum box), it always crash on Max 5.0.3 on Mac Intel & on Max 5.0.4 on XP pro


August 21, 2008 | 9:35 pm

i’ve done some tests and it crashed after :
144 seconds
47 seconds
15 seconds
6 seconds….

the most crash-attracting parameter seems to be the speed ratio

av


August 21, 2008 | 10:49 pm


August 22, 2008 | 12:24 pm

hi,

i’ve done several tests this morning,
it seems to crash with a signal vector size of 64 on Max 5.0.3 & 5.0.4 but no crash on 5.0.2

here are all the details :
emmanuel, if you need i can post OS X crash log or send you a mail

thanks

av

*****************************
* Computer 1 :
*
* Windows XP Pro SP2
* Max 5.0.4
* Intel Core2Duo 2,20GHz
* RAM 2Go
*
*****************************

10:54 22/08/2008
Driver audio : ad_mme
I/O Vector Size : 512
Vector Size : 64
Overdrive : off
Time before crash : about 49 sec.
* I was changing zigzag~ paramter with mouse when crash happens *
* One Core was overloaded after Crash (100%) *

11:13 22/08/2008
Driver audio : ad_mme
I/O Vector Size : 512
Vector Size : 512
Overdrive : off
Time before crash : about 280 sec.
* I was changing zigzag~ paramter with mouse when crash happens *

11:39 22/08/2008
Driver audio : ad_mme
I/O Vector Size : 512
Vector Size : 512
Overdrive : off
Time before crash : about 623 sec.
* I wasn’t doing anything when crash happens *

11:54 22/08/2008
Driver audio : ad_mme
I/O Vector Size : 512
Vector Size : 512
Overdrive : on
* Worked fine for more than 800 sec. *

*****************************
* Computer 2 :
* Apple MacBook Pro
* Intel Core2Duo 2.2GHz
* RAM 2Go
* Max 5.0.3
*****************************

11/10 22/08/2008
Overdrive : OFF
Driver audio : CoreAudio
I/O Vector Size : 512
Signal vector size : 64
Vector Optimization : ON
Time Before crash : about 8 sec.
Crash log file : crash_log_21
* I wasn’t doing anything particular when crash happend *

11:27 22/08/2008
Overdrive : OFF
Driver audio : CoreAudio
I/O Vector Size : 512
Signal vector size : 64
Vector Optimization : ON
Time Before crash : about 3 sec.
Crash log file : crash_log_22
* I was just clicking on Max window when crash happend *

13:32 22/08/2008
Overdrive OFF
Driver audio : CoreAudio
I/O Vector Size : 512
Signal vector size : 512
Vector Optimization : ON
* Worked fine for more than 2 hours *

13:32 22/08/2008
Overdrive OFF
Driver audio : CoreAudio
I/O Vector Size : 64
Signal vector size : 64
Vector Optimization : ON
Time Before Crash : about 7 sec.
Crash Log File : crash_log_23

13:49 22/08/2008
Overdrive OFF
Driver audio : CoreAudio
I/O Vector Size : 512
Signal vector size : 64
Vector Optimization : ON
Time Before Crash : 7 sec.

*****************************
* computer 3 :
* Apple MacBook pro
* Mac OS X 10.4.11
* Intel Core2Duo 2.16GHz
* RAM 3Go
* Max 5.0.2 (34989)
*****************************

Driver audio : CoreAudio
I/O Vector size : 512
Signal vector size : 64
Overdrive : off
Vector optimzation : on
No crash after 2 hours

Driver audio : CoreAudio
I/O Vector size : 64
Signal vector size : 64
Overdrive : off
Vector optimzation : on
* Worked fine for more than 10 minutes *

*****************************
* Computer 4 :
* Apple G5
* PowerPC G5 2 x 2GHz
* RAM 512 Mo
* Max 5.0.3
*****************************

12:00 22/08/2008
Audio Driver : CoreAudio
I/O Vector Size : 512
Signal Vector Size : 64
Overdrive : off
Vector optimization : on
Crash after : about 623 sec.
* I wasn’t doing anything when crash happend *
no log

13:30 Audio Driver : CoreAudio
I/O Vector Size : 512
Signal Vector Size : 512
Overdrive : off
Vector optimization : on
* Worked fine for more than a hour *
no log


August 22, 2008 | 12:37 pm

it still crash on Window XP pro under Max 5.0.4 with signal vector size of 512 or 1024…


August 22, 2008 | 1:23 pm


Viewing 8 posts - 1 through 8 (of 8 total)