Max6:stop sound soon with high frequency cycle~.

Nov 2, 2011 at 9:32am

Max6:stop sound soon with high frequency cycle~.

Hi,

in max6, connect cycle~ (around 10000hz) with *~ and connect right inlet of the*~ with flonum.
And rise up the value of flonum, soon the sound of this patch will stop because of too big volume.

in max5, the same patch was running without any trouble.

Do you know why, and solution?

thanks

#59744
Nov 3, 2011 at 4:21pm

Briefly trying this on an internal build I cannot reproduce.

We’ve got some fixes in for cycle~ for the incremental (6.01) update which will be due out next week. If that doesn’t fix this, then please show us the patch you are using to cause this problem

Cheers

Andrew

#215047
Nov 8, 2011 at 6:10pm

I made a very simple patch that reproduces ALWAYS the cycle~ bug – output saturates after a while.

Attachments:
  1. cyclebug.maxpat
#215048
Nov 8, 2011 at 6:15pm

Tried an two Windows 7 computers, intel i5 and i7 CPUs.

How can I upload the bug-patch to your Bug-report form?

Regards,
Jurgen

#215049
Nov 8, 2011 at 7:25pm

I can reproduce with Jurgen’s patch on Max 6. 2008 Core 2 duo MBP, Mac OS X 10.6.8, default sound card.

#215050
Nov 14, 2011 at 10:06am

Yesterday, i installed MAX6.01.And my problem of cycle~ was solved.

thank you for reply.

Regards.

kmtks

#215051
Nov 17, 2011 at 1:57am

I have the same problem with Max6.0.1 on a Lenovo Thinkpad Win7Pro 64bit…

Won’t bother posting a patch because even the MSP-tutorial#1 crashes:
As soon as the “start” message is pressed, I hear a 1000Hz cycle for half a second, then the window freezes. Then it says (not responding) and has to be forced closed.

This seems to happen with ANY audio output object.

Help??

#215052

You must be logged in to reply to this topic.