Forums > MaxMSP

MAX_EVENTS_PER_BLOCK – what does this mean and how to fix it?

February 8, 2010 | 3:36 pm

hi,

Max 5.1.2, OSX10.5.8, macbook pro

harrumph. Edited and deleted. Problem was due to stupidity on my part.

Though I do get the "MAX_EVENTS_PER_BLOCK exceeded" message from time to time, and would love to know why and how to eliminate it.

And harrumph again. I’m getting the MAX_EVENTS message when I manually trigger notes in a single vst~ synth now.

My assumption is that there’s too much info to the vst~ – but I’m only sending a single note on/pitch message for each controller key press.

Que pasa?


July 2, 2010 | 8:04 pm

I got the same message using vst. Any idea how to get rid of it?


July 2, 2010 | 8:48 pm

Send less midievents to the vst~.

I think the limit is 256 per audio signal vector.

I’m not sure why it would trigger for less events than that – may we please have some more details?

-A


July 3, 2010 | 6:14 pm

this is the subpatch

– Pasted Max Patch, click to expand. –

this is what drives it

– Pasted Max Patch, click to expand. –

July 5, 2010 | 11:31 am

If I count it right, I am sending 36 messages to a vst object. I have five objects so I am sending 180 messages at any one time.


August 31, 2010 | 8:22 pm

If this message is piling up in your Max window, check to see if you happen to be sending midievent messages to vst~ while audio is turned off. With audio off, you’ll start getting the error messages after the 256th midievent at any speed.


August 31, 2010 | 8:44 pm

Hi,

I was experiencing the same… the way i solve this; checking if the audio is ON, is important audio must be ON, and send a message like "midievent 144 $1 0" after the note message, to give velocity 0 to last event, it works for me.
hope that helps too.

Luis Marques


September 1, 2010 | 5:55 pm

I have sent the patch to cycling and we found out that the message actually appears when the dac is off and the metro is still running. So it is not a dangerous bug. I think they want to look into this and fix it.
Cheers


September 1, 2010 | 5:57 pm

There’s no bug here. Just a low priority feature request.

-A


September 1, 2010 | 6:15 pm

(could’ve just called it a "feature request", but way to rub it in the face with the addition of "low-priority", Andrew)


Viewing 10 posts - 1 through 10 (of 10 total)