Forums > MaxMSP

maxinterface.json edit troubles


f.e
April 29, 2008 | 11:49 am

Hello,

When i try to add the line :

"shortcut_windows" : "shift+L"

to "lineupconnections", Max 5.0.1 doesn’t load properly. It loads but
without the menus (File, Edit, etc). When i roll back to a clean
maxinterface.json, it’s ok.

Is there a trick to edit your own shortcuts ? Things to know (like
capital letters seem to mean "ctrl+letter")? Specific to Windows ?

cheers

f.e

ps: complete entry is :

{
"message" : "lineupconnections",
"label" : "Align Connections",
"target" : "owner",
"shortcut_mac" : "option+Y"
"shortcut_windows" : "shift+L"
},


f.e chanfrault | aka | personal computer music
>>>>>>> http://www.personal-computer-music.com
>>>>>>> |sublime music for a desperate people|


April 29, 2008 | 12:19 pm

On 29 avr. 08, at 13:49, f.e wrote:

> {
> "message" : "lineupconnections",
> "label" : "Align Connections",
> "target" : "owner",
> "shortcut_mac" : "option+Y"
> "shortcut_windows" : "shift+L"
> },

You’re missing comas at the end of one line:

{
"message" : "lineupconnections",
"label" : "Align Connections",
"target" : "owner",
"shortcut_mac" : "option+Y",
"shortcut_windows" : "shift+L"
},

ej


April 29, 2008 | 2:14 pm

Hi !

I got some problems also editing the maxinterface.json… It showed up that if you edit it with an external editor (as Smultron in my case), Max does not start normally afterwards.

I am thinking of an character encoding problem…
Which encoding should be used ? Unicode ? UTF-8 ? UTF-16 ?

Or simply edit it with Max5 ;)

Cheers


April 29, 2008 | 3:46 pm

1. Make sure smultron is not setting the Apple filetype code to something strange (we’ve heard reports of this, and I assume that unless you have errors in your formatting, that this is your issue). Using TextWrangler, TextMate, TextEdit or many other fine text editors work fine. I’m not sure why smultron has issues as I’ve never used it.

2. UTF-8 no BOM (Byte Ordering Mark), is the native character encoding for all max files. We try to detect other file encodings, but it’s not perfect.

-Joshua


April 29, 2008 | 4:35 pm

On Apr 29, 2008, at 7:14 AM, BenCello wrote:
> I got some problems also editing the maxinterface.json… It showed
> up that if you edit it with an external editor (as Smultron in my
> case), Max does not start normally afterwards.

It’s worth noting that on the Mac at least, the Console application
will point out where Max had problems parsing maxinterface.json.

-C

Chris Muir
cbm@well.com

http://www.xfade.com


April 29, 2008 | 4:47 pm

Thank you jkc

It works indeed perfectly with textedit. It’s not the first time I have some problems with Smultron concerning the coding. I don’t really know how to set it up to avoid those issues. Never mind…

Cheers


Viewing 6 posts - 1 through 6 (of 6 total)