Forums > MaxMSP

Max/Launchpad Speed Issues with Win Seven

August 9, 2010 | 2:34 am

OK i’m really not sure if i´m right with postig this here but i need help.
Ive some patches working with the novation launchpad and ive used them often and for a long time with a macbook, without any (similar) proplems..
Now i got a new laptop thats much stronger and faster than the old macbook but the launchpad reacts extremely slow..
But the problem could also lie in something max related and laso maybe somebody else in this forum encountered the same problem so i thought i’ll ask here..
Extremely slow means that it cleares the whole grid within 2 to 3 seconds.. which is unacceptable. And the really great thing about this is that Max is somehow waiting for this, so other midi events are postponed until the launchpad is updated.. I can even measure the time quite exactly with the patch at the end of this somehow desparate paragraphs.
Sooo, are there any USB driver/windows seven (64bit) related problems anybody knows about?? Any help would be greatly appreciated!

– Pasted Max Patch, click to expand. –

August 9, 2010 | 1:43 pm

a while ago i found out that the launchpad starts to get laggy if it gets too many values in short time…

there is nothing wrong with your LP or your OS.
(of course you should always check for new drivers)

have a look at this patch!

– Pasted Max Patch, click to expand. –

August 9, 2010 | 4:27 pm

Hey thanks for the reply!
In your patch, my launchpad never turns off all LEDs, but thats due to double buffering stuff im too lazy to look up, right now. had to correct the last velocity from zero to 12.
Nevertheless, there is something wrong here!
There are simply heave speed issues with the combination of a launchpad and windows seven 64 bit!!!
Also the launchpad support knows this..
thanks for the help, now im simply having the launchpad connected to my mac, sending and receiving via OSC to and from win seven..
again, thanks for the help anyways,
patrik


Viewing 3 posts - 1 through 3 (of 3 total)