Forums > MaxMSP

MAXMSP crashing consistently. Exhibition openin tomorrow :(

November 16, 2011 | 1:26 pm

Hi,

As it usually goes, MAX started crashing today after preforming flawlessly for three days on site. I use old G5 dual 2ghz desktop. osx 5.1.8, MaxMsp 5.1.9, motu 24IO with latest drivers.

The patch is big and messy and it makes no sense to post it.

Max crashes within 1 minute since I turn dac on.

Crash thread is always the same:

Thread 22 Crashed:
0 com.cycling74.saw~ 0x173b4924 saw_perform_sync_bothsignals + 816
1 com.cycling74.MaxAudioAPI 0x15dada7c dspchain_tick + 120
2 com.cycling74.MaxAudioAPI 0x15dabeb4 ad_process + 536
3 com.cycling74.ad_coreaudio 0x33e2aa74 coreaudio_ioproc + 380
4 com.apple.audio.CoreAudio 0×94457620 HP_IOProc::Call(AudioTimeStamp const&, AudioTimeStamp const&, AudioBufferList const*, AudioTimeStamp const&, AudioBufferList*) + 324
5 com.apple.audio.CoreAudio 0x944572ac IOA_Device::CallIOProcs(AudioTimeStamp const&, AudioTimeStamp const&, AudioTimeStamp const&) + 300
6 com.apple.audio.CoreAudio 0×94457160 HP_IOThread::PerformIO(AudioTimeStamp const&) + 548
7 com.apple.audio.CoreAudio 0x94455b30 HP_IOThread::WorkLoop() + 808
8 com.apple.audio.CoreAudio 0x944557f0 HP_IOThread::ThreadEntry(HP_IOThread*) + 12
9 com.apple.audio.CoreAudio 0x94443de4 CAPThread::Entry(CAPThread*) + 104
10 libSystem.B.dylib 0x97ce70d0 _pthread_start + 316

Thanx a lot

klif


November 16, 2011 | 4:08 pm

What can be argued from the crash log is that the crash happens in the saw~ object, in the audio thread – which I guess you know already.

You say that your patch worked fine until yesterday – what has changed since then? Are the different fields in the DSP status as they should be? Bad settings may lead to crashes, especially with 3rd party externals – are you using any?

Finally, what happens if you just remove the saw~ object(s)?

Sorry for being so vague, but it’s hard to figure out what’s happening with so little information…

aa


November 16, 2011 | 4:17 pm

thnx, i didn’t get the saw bit. will test now, thanx :)


November 16, 2011 | 5:43 pm

Did you resolve it? Am I crazy or does it say "thread 22 crashed". I don’t see thread 22 posted. That’ll probably give you a better indication of where the trouble starts.


November 17, 2011 | 12:20 am

that is thread 22. i only copied that part, didn’t want to post the whole crashlog.

i erased saw object in the end. it is some wierd bug and it was not so important.

by the way this is what i’m working on:

http://vimeo.com/32178004

all analog video. 24 audio channels control (CV style) modified tv sets. max controls the tv’s, three pantilt cameras, video switcher and arduino.



th
May 9, 2012 | 7:56 pm

nice


Viewing 6 posts - 1 through 6 (of 6 total)