Forums > MaxMSP

maxmsp disconnect from arduino

February 27, 2010 | 8:17 pm

I have a stationary bike connected to a an imac with maxmsp on it. When I begin biking the movie goes from black to playing a random movie located in a folder on my desktop. When I stop the movie stops and screen goes black. When I begin biking again the another movie will play randomly from the folder. This is how it is supposed to work. This will work for sometime but after a few days a video will begin playing randomly and slowly without anyone riding the bike. When looking at the MaxMsp interface the voltage reader is frozen at a certain number. I have tried the reset button on the arduino but it does not reregister the numbers. If logout and reset I am good for a little longer does anyone know why the connection between maxmsp and arduino is failing?

Please help totally desperate.

This is the tutorial I used to develop the project

http://arduino.cc/en/Tutorial/VirtualColorMixer

This is the board I am using
http://www.electrokit.se/moduler-mikroprocessor-arduino-duemilanove-usb-board_12200020

ARDUINO CODE

This example reads three analog sensors (potentiometers are easiest)
and sends their values serially. The Processing and Max/MSP programs at the bottom
take those three values and use them to change the background color of the screen.

The circuit:
* potentiometers attached to analog inputs 0, 1, and 2

http://www.arduino.cc/en/Tutorial/VirtualColorMixer

created 2 Dec 2006
by David A. Mellis
modified 14 Apr 2009
by Tom Igoe and Scott Fitzgerald

This example code is in the public domain.
*/

const int redPin = 0; // sensor to control red color
const int greenPin = 1; // sensor to control green color
const int bluePin = 2; // sensor to control blue color

void setup()
{
Serial.begin(9600);
}

void loop()
{
Serial.print(analogRead(redPin));
Serial.print(",");
Serial.print(analogRead(greenPin));
Serial.print(",");
Serial.println(analogRead(bluePin));
}

MAX PATCH

http://www.cameronmacleod.net/BIKE%201%20FILE%20OPEN%20IN%20MAXMSP%20RUN%20TIME-fullscreen%20fix3.maxpat


Viewing 1 post (of 1 total)