message to DOShack

Aug 3, 2010 at 7:29pm

message to DOShack

Hi all,

I am trying to build an interface and to automate the conversion of wav files into mp4s (m4as) using the Nero AAC encoder, which is only accessible in the command prompt (windows vista). I am using the DOShack object (by f.e.) to launch DOS applications, but when trying to use the AAC encoder I get the following error in max: ERROR:could not open wav file, which suggests there’s something wrong with the way I am sending the message? (or perhaps it cant be done?!)

I am sending this message to DOShack:
as its simplest: c:\neroAacEnc.exe -if “mix8.wav” -of “test2.m4a”
or with more encoding details: c:\neroAacEnc.exe -br 32768 -2pass -if “mix8.wav” -of “test2.m4a”
(if no folder info is entered, the default path finds the wav in the app folder, and sends the m4a file to the same folder)

these are correct in dos syntax, and work fine when written directly into command prompt. However I get the error when sending it from max.

Have you got any ideas?

tHANKS

#51623
Aug 4, 2010 at 2:45pm

not sure, but I suspect something with the quotation marks… maybe you need to put the *whole* command in quotes, but use ” or \” inside? it can be kind of squirrely

#185237
Aug 4, 2010 at 9:38pm

thanks,
i have tried putting the whole message between quotation marks, but still the same. I’ll keep trying other things, including some \ and see what happens…

#185238

You must be logged in to reply to this topic.