metro inconsitency

Aug 20, 2011 at 9:01pm

metro inconsitency

Hi all,

I’ve been reading a lot of the sometimes inaccuracy of metro.
In this very moment I’m experiencing it, because some MIDI notes go sometimes with a noticeable delay.
I also read to use phasor for a more accurate timing, and i found a mix of [phasor~] + [delta~] + [< ~ -0.5] + [edge~] to work just fine. But i can’t find an equivalent for the object [delay]. Anyone? thanks!

#58568
Aug 20, 2011 at 10:20pm

Is Overdrive on? (Options menu) Timing is tighter when Overdrive is on.

#210529
Aug 20, 2011 at 10:50pm

iep, overdrive on. but I’ve a lot of data running, and metro is simply drunk sometimes ;-)
i see that the phasor~ mix gives me way more stability, but still don’t know a best way to minimize tempo-shifts…

#210530
Aug 21, 2011 at 12:23pm

mmm… no one? oh, yes… it’s sunday!

#210531
Aug 21, 2011 at 12:29pm

how about using count~ as your metro?

you could use another count~ module as delay as well – with the proper modulo value.

sorry for all the editing :P

hth

– Pasted Max Patch, click to expand. –
#210532
Aug 21, 2011 at 5:31pm

Maybe I’m not as picky as you are, but I’ve had pretty good success with metro in overdrive. My step sequencer on steroids is all run off of metro, with either internal timing or slaved to MIDI clock.

Unless you can run things entirely in the signal domain, you end up moving back into the scheduler domain, and most of the gains that you might get from the signal domain are nullified.

Perhaps you should post your patch so that people can see where any bottlenecks might be.

#210533
Aug 21, 2011 at 6:01pm

@yp: thanks for the patch, but i don’t know if it’s possible to adapt that structure, because my patch works on beats and not milliseconds…
@Chris: max is in overdrive but i always hear sliggish delays which does not corrispond entirely to what they are meant for. Maybe that’s because I have a very large patch, at least to some extend (10 mb circa). That’s the reason why it would be a mess to post it…

by the way, this is what i use for metro (of course together with a transpose object)
This way metro works fine, but if i record for instance a MIDI melody with [borax] when i replay the melody it is veery different. so slooower *_* what could it be? Any idea why?

– Pasted Max Patch, click to expand. –
#210534
Aug 21, 2011 at 6:57pm

I run a Big Patch and I need a perfect sync within events.
From my experience, extensively using max > jitter > msp at the same time
and paying attention that CPU doesn’t go over 40%,
only qmetro in conjunction with a counter make me happy.
All the msp methods don’t provide me the sync I need,
even changing the ms interval or the scheduler preferences.
I think Low Priority is the way…

#210535
Aug 21, 2011 at 7:42pm

Here’s a patch that does some analysis on signal versus scheduler clock. On my system they are close enough for either of them to be useful. While qmetro is essential for Jitter, for MIDI it’s close to worthless, IMO.

– Pasted Max Patch, click to expand. –
#210536

You must be logged in to reply to this topic.