Forums > Max For Live

MFL device not shown in Clip Envelope Dropdown

August 7, 2010 | 4:19 pm

The device I wrote in MFL is not in the envelope panel device dropdown of clips in the track where the device is deployed. But it does show up in the ‘M4L.api.SelectDevice.Maxpat’. How can this be fixed?


August 7, 2010 | 9:39 pm

In the "parameters" window, you’ll find a "order" column for your objects. Give you’re desired dials, buttons… you want to see in the envelopes a number (preferably starting from 1, as it’s also the way to choose what you want with the blue hand).


August 8, 2010 | 5:46 pm

That’s what I did already, but the device still did not show up. The order of parameters can be set that way though. The Pluggo devices do show up, and the PureMagnetic stuff does also.

Is there an option for this somewhere?
Is someone from the Cycling ’74 staff reading this?


August 8, 2010 | 9:03 pm

You need to specify a modulation type for each parameter you wish to modulate using clip envelopes. This is not switched on by default, as there are multiple modulation types a programmer may choose for each parameter. Check the parameter tab in the object’s inspector for the Modulation Mode attribute.

Cheers

-A


August 9, 2010 | 6:37 pm

Thanks Andrew, it’s working now.

Kind regards,

Willem.


August 15, 2010 | 3:37 pm

i have an odd issue, i have a bpatcher with visible parameters. they show up, but their short names were generic so i changed them. but their new names do no populate. i have quit, i have restarted. i have cut and pasted the bpatcher…i am confused. i fell like i am missing a simple step.

EDIT: i was. i had to change the short name in the main patcher (as well? or instead?)


September 21, 2010 | 8:22 pm

any update on this? My modulation mode parameter is greyed out in the inspector. did a search and checked the help


Viewing 7 posts - 1 through 7 (of 7 total)