MIDI delay problem

Jun 27, 2006 at 11:45pm

MIDI delay problem

Hi all,

Sorry to bother you again with this problem. But I still would like to know that if the MIDI device input delay is a problem related to my computer or the Max setting? Do you have ever met such problems?

Thanks Trond, I’ve tried to use Max’s scheduler to improve MIDI input accuracy, but that doesn’t seem to make much difference. Thank you again.

The following is my original question and Trond’s suggestion.

Trond’s suggestion,
>Hi Sherie,
>
>try fiddle with the “Max Scheduler in Overdrive” >and “Scheduler in Audio Interrupt” settings in the Options DSP >Options menu, and see >if they make any difference. If so, you >can check out MSP45TutorialsAndTopics.pdf page 36 – for more >details on the settings, in particular the two options >mentioned above are explained >further at page 41.
>
>Best,
>Trond

My problem:
>> Hi all,
>>
>>Since I’m a new comer to the Max environment, I met a few >>problems when setting up the midi controller to Max. So I >>would like to ask for your opinions.
>>
>>Currently I have a midi keyboard connected to the Max >>patches to make the notes in, but there is a huge delay >>between the keys you hit and the sounds Max could make. Here >>is my configuration information,
>>WinXP, Intel 1.4G, 256Mb, Max/MSP(demo) 4.5.2 with Jitter, >>Roland D5 keyboard(usb). The simplest Max patches I used to >>test contains only notein followed by noteout object, and >>that would also cause the delay problem.
>>
>>I would like to know whether you have such problems, and if >>so, how you solved them.
>>
>>Thanks a lot.
>>
>>Sherie

#26594
Jun 28, 2006 at 1:57pm

i have to set the io and signal vector size smaller for midi to work
fast enough, with some of my percussion patches. 128 or 64, less than
64 caused audio glithes in my fx loops. more than 128 and i felt like
i was trying to play the drums after 5 too many beers, every slowed
down ……. . . . . . . . . .

> Sorry to bother you again with this problem. But I still would
> like to know that if the MIDI device input delay is a problem
> related to my computer or the Max setting? Do you have ever met
> such problems?

#79753
Jun 28, 2006 at 4:08pm

btyw wrote:
> Sorry to bother you again with this problem. But I still would like
> to know that if the MIDI device input delay is a problem related to
> my computer or the Max setting? Do you have ever met such problems?

I don’t have these problems, but I am on a Mac. You said there is a huge
delay, but what is huge (2 ms or 100ms or what…)
Then try to find another way to route Midi from in to out directly. For
example a sequencer might be able to do that or Midi yoke or whatever
would allow to route Midi in to out through your operating system. If
the delay is still there its not a Max issue…
You didn’t tell us what you are addressing with Midi, an internal synth,
an external synth a Yamaha Disclavier ???
You could eventually directly connect your devices with a Midi cable…

Let us know what you did, to track down the problem, and what makes you
believe its a Max problem…
If somethings going wrong, there are a lot of places to consider…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#79754
Jun 29, 2006 at 3:11am

Hi,

Thanks a lot for your reply. I’m using a Roland D-5 keyboard through the m-audio usb port into the pc. I have a cable that connected the keyboard output directly to the microphone input, and the notes were not delayed. The same with routing midi signal through midi-yoke. I don’t know how to measure the delay accurately but it’s about 200ms or more. The smaller I/O vector size doesn’t sound changed anything by far.

In the DSP setting menu, if I chose directsound as the driver, there would be a minimal 10ms latency in the following option. Will that affect the timing issue? And the rewire choices doesn’t make sense either.

Thank you all. I’ll keep trying.

Sherie

#79755
Jun 30, 2006 at 8:49am

btyw wrote:
> I don’t know how to measure the delay accurately but it’s about 200ms
> or more. The smaller I/O vector size doesn’t sound changed anything
> by far.

Audio settings should not affect Midi latency. 200ms seems way out,
never heard about that.
To test the Midi connection I assume you have set the synth to “local
control off” to be only played by Midi if thats your sole Midi sound
source. (Elsewise you would hear both, the direct and the Midi
controlled sound)
If Midiyoke works fine try the following: just
connect [midiin] – [midiout], set the out port by double clicking midiout.
Does this work fine?
If yes, the problem is within your patching…

Stefan


Stefan Tiedje————x——-
–_____———–|————–
–(_|_ —-|—–|—–()——-
– _|_)—-|—–()————–
———-()——–www.ccmix.com

#79756

You must be logged in to reply to this topic.