MIDI file from Sibelius loops on its own in seq

Jun 2, 2012 at 6:35pm

MIDI file from Sibelius loops on its own in seq

Hi!

A bit frustrated trying to get a MIDI file exported from Sibelius 6 to play in seq-object WITHOUT looping. There is no “bang upon completion” from the right output of seq. I’m starting to think this is some Sibelius bug. But I’m hoping someone has a work around?

A bit of a panic, too! Need to get this ready yesterday!

Thanks!

Girilal

#56196
Jun 2, 2012 at 8:29pm

Are you sure that the exported midi file has format 0 ?

#201688
Jun 2, 2012 at 10:30pm

Yes, it’s format 0. I’m sure, because I made a format 1 first, which wouldn’t work at all…

#201689
Jun 3, 2012 at 1:17am

Have you tried playing the file with some other sequencer program?
Or you could upload the file here and we may find out what’s going on.

#201690
Jun 3, 2012 at 7:13am

Thanks broc! I’ve uploaded one file which auto-loops for some reason.

No, I haven’t tried another sequencer, really. I very seldom work with MIDI files, so I wouldn’t know what to do with it in another program either.

I’m guessing that Sibelius simply exports rather dirty MIDI…

Attachments:
  1. Maejejf1.midi
#201691
Jun 3, 2012 at 10:09am

For me the file plays correctly in other sequencers, but also in Max. Duration is about 2 min.

– Pasted Max Patch, click to expand. –
#201692
Jun 3, 2012 at 7:53pm

broc!

Thanks for checking it out! What you say makes me realise that Sibelius is exporting way too much as a MIDI file! Instead of just an excerpt, which is what it is supposed to do… Well, my fault! Thanks a lot, you did straightened me out as to what was wrong: faulty human operator!! (As so often…)

Cheers!

#201693

You must be logged in to reply to this topic.