Forums > Max For Live

Midi – notein problem, help please.

January 22, 2011 | 10:48 am

I’m using three midi tracks, each sending one note at a time, each midi track on different channels.
inside max I need to display the three notes from the 3 tracks, as 3 numbers – using notein 1, notein 2 & notein 3 into 3 number inspectors.

When i close and restart ableton it stops working and the number inspectors shows the same numbers (from one midi track only), and in order to get it back on track, i have to make three new notein objects and it works again…until I restart.

How do i get it to work without having to make three new notein objects every time i launch my project ?

Thanks,
Rasmus


January 22, 2011 | 11:19 am

Hi Rasmus,
without seeing the patch it’s hard to check for the problem. To me it seems that you forget to tell the [notein] from which device to take the info. You can double-click on it to set it or let it be done by Max, see patch below. It’s a basic thing so possibly you already did this. If so than i guess people would like to see the patch to check it.

– Pasted Max Patch, click to expand. –

Hope this will help. Good luck!!

john.


January 22, 2011 | 11:30 am

Hi John,
I did the routing inside ableton and the patch look like this:

– Pasted Max Patch, click to expand. –

apparently it’s not able to seperate the channels if i restart :)

/Rasmus


January 22, 2011 | 12:44 pm

M4L midi effect devices are not able to separate the channels.

For being able to separate midi input channels the M4L device type must be an *instrument*, ie. built from a Max instrument template. In this case the device can be used like a "multitimbral" instrument (explained in the Live manual).


January 22, 2011 | 12:54 pm

Hi Broc,
It allready is a Max "instrument"… still can’t manage to get it to work though…


January 22, 2011 | 1:03 pm

Then it should definitely work.
Make sure that Midi From of the instrument’s track is set to ‘No Input’.


January 22, 2011 | 1:23 pm

It does work when i make the notein objects. As soon as i close ableton and open the project again… the notein objects loses track of the channels and all just display channel 2, though they’re set to notein 1, notein 2 and notein 3

Can’t get john’s patch to work… I somehow need to tell the notein objects more specificaly where to get the note info from.


January 22, 2011 | 1:50 pm

Well, John’s patch doesn’t work as it refers to external midi ports.

It seems the selection must be done at run time. Try this.

– Pasted Max Patch, click to expand. –

January 22, 2011 | 2:53 pm

My mistake, sorry for that. Great that you got other people to help you out!!


January 22, 2011 | 3:30 pm

Thanks a lot broc and john !! Works like a charm now !! the gate did the trick :)


January 22, 2011 | 4:10 pm

Glad to hear. So I’ve learned something too..


January 22, 2011 | 7:17 pm

Just wanted to add that [gate] may not be the best solution here due to possible timing problems. So I think using [route] would be better.

– Pasted Max Patch, click to expand. –

Viewing 12 posts - 1 through 12 (of 12 total)