Midi – notein problem, help please.

Jan 22, 2011 at 10:48am

Midi – notein problem, help please.

I’m using three midi tracks, each sending one note at a time, each midi track on different channels.
inside max I need to display the three notes from the 3 tracks, as 3 numbers – using notein 1, notein 2 & notein 3 into 3 number inspectors.

When i close and restart ableton it stops working and the number inspectors shows the same numbers (from one midi track only), and in order to get it back on track, i have to make three new notein objects and it works again…until I restart.

How do i get it to work without having to make three new notein objects every time i launch my project ?

Thanks,
Rasmus

#54533
Jan 22, 2011 at 11:19am

Hi Rasmus,
without seeing the patch it’s hard to check for the problem. To me it seems that you forget to tell the [notein] from which device to take the info. You can double-click on it to set it or let it be done by Max, see patch below. It’s a basic thing so possibly you already did this. If so than i guess people would like to see the patch to check it.

– Pasted Max Patch, click to expand. –

Hope this will help. Good luck!!

john.

#196394
Jan 22, 2011 at 11:30am

Hi John,
I did the routing inside ableton and the patch look like this:

– Pasted Max Patch, click to expand. –

apparently it’s not able to seperate the channels if i restart :)

/Rasmus

#196395
Jan 22, 2011 at 12:44pm

M4L midi effect devices are not able to separate the channels.

For being able to separate midi input channels the M4L device type must be an *instrument*, ie. built from a Max instrument template. In this case the device can be used like a “multitimbral” instrument (explained in the Live manual).

#196396
Jan 22, 2011 at 12:54pm

Hi Broc,
It allready is a Max “instrument”… still can’t manage to get it to work though…

#196397
Jan 22, 2011 at 1:03pm

Then it should definitely work.
Make sure that Midi From of the instrument’s track is set to ‘No Input’.

#196398
Jan 22, 2011 at 1:23pm

It does work when i make the notein objects. As soon as i close ableton and open the project again… the notein objects loses track of the channels and all just display channel 2, though they’re set to notein 1, notein 2 and notein 3

Can’t get john’s patch to work… I somehow need to tell the notein objects more specificaly where to get the note info from.

#196399
Jan 22, 2011 at 1:50pm

Well, John’s patch doesn’t work as it refers to external midi ports.

It seems the selection must be done at run time. Try this.

– Pasted Max Patch, click to expand. –
#196400
Jan 22, 2011 at 2:53pm

My mistake, sorry for that. Great that you got other people to help you out!!

#196401
Jan 22, 2011 at 3:30pm

Thanks a lot broc and john !! Works like a charm now !! the gate did the trick :)

#196402
Jan 22, 2011 at 4:10pm

Glad to hear. So I’ve learned something too..

#196403
Jan 22, 2011 at 7:17pm

Just wanted to add that [gate] may not be the best solution here due to possible timing problems. So I think using [route] would be better.

– Pasted Max Patch, click to expand. –
#196404

You must be logged in to reply to this topic.