midi objects – trying to send a port message

Apr 16, 2010 at 8:51pm

midi objects – trying to send a port message

let me prepend this with: i have the latest update of max 5

i am using some midi objects (noteout, ctlin etc) and one of the things you can do is double click on the object to select the midi port you want that specific object to listen to. you can do the same thing by sending the object a message “port [symbol]” whereas the symbol is the name of the port you want that object to listen to…. or so i thought.

this is what the .maxhelp file says and the reference page but its not working. i’ve sent the message properly and it doesnt change that object’s midi path.

anyone else have the same issue???? any ideas for me setting up this patch without having to goto every one of my objects and changing them by hand????

thanks
GW

#49814
Apr 16, 2010 at 9:27pm

If your port name has a space in it, you will have to slap quotes around the name.
e.g. port “from MaxMSP 1″

#178880
Apr 16, 2010 at 9:30pm

just tried that and as soon as i clicked off the message object the “” disappeared.

But here’s some good news: i figured a way around it. i used the object midiinfo to generate the list of possible midi devices and then did a send object to set the other midi object.

but thanks for the help, although i still fell like this is a small bug that i hope the lovely people at cycling74 can fix on the next update

GW

#178881
Apr 16, 2010 at 9:32pm

to clarify i shouldn’t have said “… midiinfo to generate the list…” because it doesn’t generate a list it will however populate a umenu object from which to choose from.

GW

#178882
Apr 16, 2010 at 10:22pm

I can’t explain why your quotes disappeared, it has always worked for me. I don’t consider this a bug.

– Pasted Max Patch, click to expand. –
#178883
Apr 16, 2010 at 11:21pm

Ohhhhh i see what happened, im an idiot. i wasn’t spelling the device name properly, its case sensitive duh!!!

sometimes staring at the computer screen for too long is bad for the brain.

thanks so much for your help though!

GW

#178884
Aug 26, 2010 at 3:04am

Edit: nothing to see here, move along… sorry about that, I thought I had a ctlin port setting bug but I was kidding myself…

#178885

You must be logged in to reply to this topic.