MIDI (seq) not in time!

Feb 12, 2010 at 7:51pm

MIDI (seq) not in time!

Hey everyone,

I don’t have a lot of time so I’m sorry if I am repeating a previous topic as I didn’t have all the time in the world to search the forums. I am trying to build a simple MIDI sequencer that sends MIDI to VSTs or Cubase (through ad_rewire). The goal is to be able to change the tempo of the MIDI playing (using [tempo]) and to select any MIDI file to play, sort of like a MIDI DJ.

My issue is that when I use [seq] to play a MIDI file, my output has bad timing. It doesn’t keep straight time! I’m trying to play techno files and so it is dreadfully obvious when the timing is off! Also, I recorded the MIDI input going into Cubase and it was totally off the mark! I have tried using [tempo] with it and no difference. I have tried it on both a PC and a Mac to no avail.

Does anyone have a solution??? Thanks!

#48452
Feb 12, 2010 at 8:20pm

Did you turn on overdrive? And eventually “scheduler in audio interrupt”? Maybe you should.

p

#174231
Feb 12, 2010 at 8:28pm

I tried overdrive alone and then with scheduler in audio interrupt and there was barely any difference. Thanks anyways Patrick.

#174232
Feb 12, 2010 at 11:16pm

I didn’t think you could change the playback tempo of [seq] after you started playing. Unless you’re using a “next” message system. Maybe try [detonate]?

Though playing back [seq] at the default tempo (1024) should play back your file rock-solid. I don’t know what’s happening there. My laptop is a bit stuttery with this sort of thing, but my desktop is totally fine.

Try some other scheduler settings as well, like less slop and whatever else might help with timing. I think the only pretty-much guaranteed way to get solid timing is to use audio objects to generate the timing, with Overdrive/Audio Interrupt enabled. That’s worked great for me. So… and this is a general question going out to any and all wizards… does changing these settings make any difference when using something like [seq]? And if not, how can we ensure proper timing? I realize that things like [metro] will drift, but [seq]? Seems like it should have additional timing tightness built-in, if that’s possible. And I know there’s seq~, but that’s not for MIDI files.

#174233
Feb 14, 2010 at 6:32pm

Using [seq]‘s timing does mean that one cannot timing while it is playing but I was using the [tempo] object to send “tick” messages. I found it strange that both [seq]‘s timing and [tempo]‘s seemed off. I will experiment with [detonate] and let you all know my findings. Thanks for the help and please keep it coming.

#174234
Feb 16, 2010 at 10:17pm

Bad news. On my laptop at least, [detonate] is not output MIDI in straight regular tempo. I will try my iMac later but I might start looking for another solution.

#174235

You must be logged in to reply to this topic.