Midi settings not saved

Apr 22, 2009 at 10:52pm

Midi settings not saved

Hi everybody,
I want to mute some midi inputs and outputs to avoid conflicts with ableton live. So, I deselect the unwanted inputs and outputs in the midi settings. But, for some reason, it appears to be not saved when I reopen max. Am I missing something?

#43489
Apr 22, 2009 at 11:15pm

I’ve also noticed unexpected behavior.
In particular, I’d like to disable the ports created from Max as I prefer working with IAC built into Mac OS X.
But although unchecked the ports still appear in the drop-down menu of the patches.

#156028
Apr 23, 2009 at 8:53am

I find it very annoying. I got to be careful to launch ableton before max, so max doesn’t “eat” my soundcard’s midiport in ableton.

#156029
Apr 23, 2009 at 9:01am

Ok, I’ve double-checked the issue.
For me (on Mac) the MIDI settings are saved and recalled correctly.
It’s just confusing that the disabled ports are still available in the patches for selection.

#156030
Apr 23, 2009 at 9:26am
chapelierfou@hotmail.fr wrote on Thu, 23 April 2009 10:53
I find it very annoying. I got to be careful to launch ableton before max, so max doesn’t “eat” my soundcard’s midiport in ableton.

Yes, I’ve noticed this effect also when using ableton together with other software which creates its own ports. So the problem seems related to dynamic port creation in general and not specific to Max. That’s why I prefer using IAC only for midi routing.

So, does anybody know if it’s possible to prevent the port creation of Max?

For example, in Plogue Bidule this can be set in the preferences!

#156031
Apr 23, 2009 at 9:49am

Weird…
I am on XP, using a Presonus FP10.

#156032
Apr 23, 2009 at 10:14am

I’m using a lot of different audio software, and so far I’ve experienced this problem of port “eating” only with ableton. However, not all programs that create virtual ports do actually confuse ableton. So Max could also be part of the problem.

But I can confirm that the solution/workaround you’ve found seems to work reliably, ie. launch ableton first before any other software that dynamically creates virtual ports like Max.

#156033
Apr 26, 2009 at 10:18am
chapelierfou@hotmail.fr wrote on Thu, 23 April 2009 11:49
Weird…
I am on XP, using a Presonus FP10.

I’d suggest to send an email about the issue to Max support.
I’ve done this already but it may be helpful to provide more information, especially steps for reproducing the behavior.
BTW, meanwhile I’ve found that launch order does NOT always cure the problem for me.

#156034

You must be logged in to reply to this topic.