Forums > MaxMSP

Midiformat or midiout problem

May 6, 2013 | 1:57 pm

Hi, I’m working on a generative piece, involving 16 slightly different versions of the same midi device. The problem is, after a while some of the plugins stop sending midi note information to the instrument. The notes are definitely reaching midiformat, and I believe midiformat is sending something to midiout (don’t know enough about raw midi to be sure it’s right) but the midi is not reaching live. If I click the edit button in live, then close the edit window, it starts working again, but then fails again after a short while. Can’t for the life of me work out what the issue is here. If there was something I could do to get the patch to sort of "jog" itself every once in a while and work again that would be great, but I can’t work out what this would be. Any help would be greatly appreciated. Thanks!


May 6, 2013 | 3:28 pm

It sounds like some kind of "congestion". Are you sending a lot of midi data?

Maybe you could post a typical version of your patch/device.

http://cycling74.com/forums/topic.php?id=36405


May 6, 2013 | 3:38 pm

Hi broc, thanks for the help. There isn’t loads of midi data being sent out of each individual device, but there is quite a lot in total, would this make a difference? The idea is that a device on another track is sending it’s midi notes to the 16 other devices in a cycle so the sounds don’t overlap on each track. Here’s the patch:

– Pasted Max Patch, click to expand. –

The only difference with the others is the receive objects argument. If congestion is the issue, is there an easy way to "clear" things up and start again? Thanks again.


May 6, 2013 | 4:01 pm

From a quick look at your patch I guess you’re filling up the undo history by sending cc values to multiple instances of [live.object]. This can be avoided by using [live.remote~] instead.


May 6, 2013 | 5:58 pm

I think I’ve sorted it, as far as I can tell it was the lack of note offs that were causing the problem so I’ve used makenote and that seems to have cleared it up. live.remote sounds much cleaner though so I’ll change that too. Thanks!


Viewing 5 posts - 1 through 5 (of 5 total)