Minor workflow inconsistency with the [node] object

Oct 23, 2013 at 8:05am

Minor workflow inconsistency with the [node] object

I recently discovered the [node] object and it is the perfect interface for the task I needed. (Although it seems to run pretty heavy. I don’t really need the visual interface as much as I need a circular paradigm with overlapping parameter fades. Perhaps there is another way to do this.)

While working with [node], I noticed a minor inconsistency that, if fixed, would make some things easier.

When using the “setsize” message, if you select a non zero index, you can adjust the size of an individual node, but if you select the zero index, the size change will be applied to All nodes equally (“yay!”).

But, while using the “setnodead” message for Index, Azimuth, and Distance, with a pak, if you select the zero index, it Does Not, affect all nodes equally. (It would be convenient if it did.)

Again, I know that the [node] device is capable of doing much more interesting and powerful things, but for my needs, I really just need some sort of way to scan through 16 values with “crossfades” (overlapping nodes) AND I need the last one to loop back to the first, hence the 2D circular paradigm.

Also, is it possible to have more than one Knob (or scanner dot) in a single [node] object? I’m sure I could get the same outcome with multiple instances of node but one by itself is already bogging down my patch pretty bad. (But I also haven’t done any action prioritizing [because I haven't learned how to do that yet])

#268891
Oct 23, 2013 at 8:11am

Here’s part of my patch:

<code>

– Pasted Max Patch, click to expand. –

</code>

#268892

You must be logged in to reply to this topic.