Forums > MaxMSP

Moving line

May 30, 2011 | 10:38 am

Hey guys

I have a question. I want to make a line which moves between two points of which one point is fixed and the other moves. Now my problem with the current script is that it generates a new position but the line fails to recieve the new position to move.

thanks in advance

– Pasted Max Patch, click to expand. –

June 1, 2011 | 11:36 am

Hi

There seems to be a problem in relaying the co-ords through the message boxes. For starters, using the right inlet of message merely replaces the contents and not outputing them. Also I’m not entirely sure what giving the message [position] to [lineto] does but I’m sure it’s not needed. Keeping the message boxes in place, I’ve thrown in a [t b b b] to bang the outputs in good order. Hope this mod helps in some way.

– Pasted Max Patch, click to expand. –

The last bang going to [lineto] isn’t actually needed….my bad.


June 1, 2011 | 11:36 am

Hi

There seems to be a problem in relaying the co-ords through the message boxes. For starters, using the right inlet of message merely replaces the contents and not outputing them. Also I’m not entirely sure what giving the message [position] to [lineto] does but I’m sure it’s not needed. Keeping the message boxes in place, I’ve thrown in a [t b b b] to bang the outputs in good order. Hope this mod helps in some way.

– Pasted Max Patch, click to expand. –

The last bang going to [lineto] isn’t actually needed….my bad.


Viewing 3 posts - 1 through 3 (of 3 total)