Forums > MaxMSP

mpeg7 audio encoder for max msp with free recycle slice style example patch

June 26, 2009 | 2:13 pm

I’ve written my first fully fledged max external in mxj, it’s an mpeg7 audio encoder that will eventually (sometime next week) interface with the js sqlite database in max but basically think think slice~ married to analyzer~.

http://registeringdomainnamesismorefunthandoingrealwork.com/blogs/wp-content/uploads/2009/06/mpeg7encoder.jpg

It’s now stable enough to give away and I’ve made a recycle style slice patch to showcase some of the elementary features of the external.

http://registeringdomainnamesismorefunthandoingrealwork.com/blogs/wp-content/uploads/2009/06/frecycle.jpg

You can dl the jar and installation instructions here

DL: mp7max-alpha-release.zip

It’s windoze only right now pending me getting my hands on a mac to compile the classes, but the source code and eclipse project is avaialbe on sourceforge for the interested.

source

Let us know if it works and what you think.


June 27, 2009 | 11:10 am

great work robin. i attached a version that works on mac with and a slightly modified help patch to format the path message correctly (i think java has some problems with the full path, or maybe the space in Macintosh HD).

oli


June 28, 2009 | 7:21 pm

Cheers Oli, the path error with the mac was something I was working on so cheers for beating me to it. Java doesn’t seem to like the drive name at the start of the path.


June 30, 2009 | 1:19 pm

thanks, this sounds interesting!
But so far on my Mac (0S 10.5.7, Max 5.0.7) I’m getting this error: UnsupportedClassVersionError: Bad version number in .class file

screenshot of the max window attached.

The mp7max.jar and the mac version of Mpeg7Encoder.jar are in cycling/java/lib


June 30, 2009 | 8:31 pm
Quote:
The mp7max.jar and the mac version of Mpeg7Encoder.jar are in cycling/java/lib

Hmm I think you meant the mac version of the mp7max.jar ? Try re downloading oli’s recompilation of my source and put that in /java/lib/

If you’re already running with Oli’s jar and your still getting errors then maybe it’s a jre error. I don’t know what mac oli has but I’m guessing it’s an intel, is yours? (i know it probably is if your os 10.5.7). maybe you both have different versions of the jre (i.e. if his javac was more recent than your jre then it might not run).

I’m going to recompile the latest source at the end of the week on my mac in sarc and add the classes to the jar so it should be win and mac friendly (no max install though so it’s hard to check if it works ok).

let me know if you get this working or not, your feedback is appreciated.


July 1, 2009 | 9:46 pm

hello,
i tried the max version, puted the oli’s version as you said
but its not working…
i attach a picture of the error i got

thanks!


July 2, 2009 | 9:35 am

Hi freeka,

Looking at your mxj system classpath I can’t see either the MPEG7AudioEnc-0.4-rc3.jar or Oli’s Mpeg7Encoder.jar. You just need to copy both jars to your Cyclin’ 74/java/lib directory, quit max, restart and try again.

Let me know how you get on.

crx


July 2, 2009 | 1:20 pm

thanks, it was the MPEG7AudioEnc-0.4-rc3.jar I needed
working here now
MBP 2.4, 0S 10.5.7, Max 5.0.7


July 2, 2009 | 6:05 pm

thanks! it works now Wink


May 4, 2010 | 7:21 am

Hey..

Does anyone have the Mac version? It doesn’t seem to be online here anymore as far as I can see?

Cheers


May 4, 2010 | 2:17 pm

here are the jars that were working for 0S 10.5.7, Max 5.0.7
hth


Viewing 11 posts - 1 through 11 (of 11 total)