Forums > MaxMSP

Msp to Slow??????


Sym
May 4, 2012 | 12:32 pm

Hey Guys, I’m currently developing an interactive Instrument for an exhibition.

As soon as the User touches the controller surface the Instrument starts Playing and the Backgroung music fades out and vice versa.

Now the Instrument itself uses only MSP objects. The background music is randomly generated with Max objects and two vsts hosted inside Max.

With the Background Music subpatcher deleted in the Patch the Instrument creates the Sound straight with the Metro.

But when I insert the Music subpachter everything slows down and only some notes are generated not according to the metro. My CPU usage although never goes over 40%. (Mac Book Pro late 2011, Lion and Max 6)

I set the Cpu usage Limit in the Max Preferences already at 100%!

Anyone got an idea?


May 4, 2012 | 4:38 pm

- go to DSP preferences, turn overdrive ON.

– what does the CPU meter say? if it is close to 100%, you have two options: use a faster hardware or optimize your coding.

-110



Sym
May 4, 2012 | 4:43 pm

I really can’t find a problem. My Cpu usage is at maximum 40%.



Sym
May 4, 2012 | 4:54 pm

Think is found the reason. I send two lists to the zl.compare object that changed every 100ms. Since deleted everything goes smoother again. But can this really be such a big problem?

Would be glad for an answer.



MIB
May 4, 2012 | 6:15 pm

hard to tell without a patch to look at…


May 6, 2012 | 11:18 am

I was having some similar problems a while back although they didn’t involve zl.compare. I found that initially going through my patch ridding it of any superfluous objects such as number boxes etc made quite a big difference. I also found that synchronising all my data by using buddy and pack objects, as well as generally finding more elegant solutions to things where appropriate, made things a lot smoother. You could also try adjusting the vector size in the DSP preferences. I generally ignore the CPU meter in Max/MSP and go by the one in Activity Monitor in OSX. When my Macbook (2.16 DuoCore) is running at 40% in the Max CPU meter then the one in Activity Monitor usually says it’s running at about 120%!

As MIB says it would help to see your patch


Viewing 6 posts - 1 through 6 (of 6 total)