Forums > MaxMSP

Multichannel Sound on Windows

May 29, 2010 | 4:28 pm

Hello there. I have a bit fo a hardware issue and I can’t find any help for it.

I am trying to output more than 2 individual channels on Windows, using a dac~ object with 4 inlets (dac~ 1 2 3 4) and an Asonic/Asound 7.1 Channel USB Sound Card.

On Mac I can simply set the output device to the external sound card, and use the Soundflower 16 Channel drivers.

On Windows I can’t find any drivers that let me output the individual channels. Windows does recognise the device and will play to all 8 channels, but the input/output mappings only allows me to send ‘Left Channel’ and ‘Right Channel’ to each of the 8 outputs.

Can anyone help me? My DSP Status Windows options for devices/drivers are shown below.

http://img.photobucket.com/albums/v636/orrinward/DSP-Status.jpg

This is where my input/output mapping seems to fail. Sound does play out of all 8-channels, but the mapping only allows me to select from 2, rather than the 4 separate ones I have on my dac~ object.

http://img.photobucket.com/albums/v636/orrinward/IO_maps.jpg

This is the information given by my USB Sound Card:

http://img.photobucket.com/albums/v636/orrinward/USB-Device.jpg

Here is the Sound Card I am using (product specifications are on the page). I’ve installed the latest drivers for it on my Laptop, and as I said, Mac lets me do it just fine. I need it to work on Windows as my S-Video input device (also used in the patch) is Windows only.

If it helps at all, I am running Windows 7 64-Bit.


May 29, 2010 | 6:00 pm

Try using ASIO4all. You can download it (it is free) then use it as the device driver in the DSP settings. Hope this helps.


May 29, 2010 | 6:36 pm

I have ASIO4ALL (or something claiming to be it) Installed and viewable in my drivers options, but when I select it this is what I get:

http://img.photobucket.com/albums/v636/orrinward/asio4all.jpg

See, it doesn’t show me any device options, just this strange ‘Big Ben’ thing…


Viewing 3 posts - 1 through 3 (of 3 total)