Forums > MaxMSP

Multichannel Waveform~ Bug

January 5, 2014 | 7:03 pm

Hi, I’ve been having a frustrating time working with multichannel display in waveform~. As per the help file, I’ve been using the @name attribute to specify the different channels. I’ve attached a patch where I’ve described some of the odd behavior I’ve been experiencing.

For those who can’t download the patch, here’s what I’ve commented inside the patch:

Upon startup, I get this error message:

waveform~: channel 1 out of range (buffer~ #0_soundplayer has 0 channels)

waveform~ displaying channel 1

Check out the inspector on both of these waveform~ objects, looking at the channel number. The top one is set to channel 0, and the bottom is set to channel 1!

My "name" attribute should have set those to channels 1 and 2, correct?

Try loading a stereo file and see if the waveform displays correctly.

On my computer, only the top waveform~ object displays, showing channel number 2. Unlocking and relocking the patch (or clicking on the waveform~ object) causes the bottom waveform~ to refresh showing channel number 1.

Clicking on my two "name" attribute message boxes doesn’t do anything.

Sometimes I can’t change the channel assignment in the inspector. They’re stuck on channels 0 and 1.

Finally, try loading a different stereo file. The bottom waveform~ retains the previous file’s waveform until you unlock/relock or click around in the patch.

What’s going on here?? I’d appreciate any explanation or help.

– Pasted Max Patch, click to expand. –

January 6, 2014 | 6:18 pm

Hi, has anyone found a chance to download my patch and check it out? Can anyone confirm the waveform~ errors that I’m experiencing? Thanks!


January 9, 2014 | 11:29 am

I’m surprised no one has tried the patch and reported that these issues are occurring? Are these known issues with waveform~?


January 9, 2014 | 12:30 pm

I can reproduce some problems here and I’ll take a closer look. As a workaround, you may want to use other attributes in the meantime, like @chanoffset.

Best,
-Ben


January 9, 2014 | 1:09 pm

Hi Ben, thanks for your reply. I’m glad it’s not just my computer. As far as I’ve researched, the @chanoffset parameter is restricted to 0 – 4. This is a problem if, for example, you load an 8-channel file. Does that make sense?


January 9, 2014 | 1:20 pm

Ideally, what I’d like to be able to re-create in the patch window is the floating buffer display window (see attachment). Any suggestions?

Attachments:
  1. Screen-shot-2014-01-09-at-3.16.49-PM

January 9, 2014 | 2:51 pm

As far as I’m aware, buffer~ only allows up to four channels, so this wouldn’t work for a single buffer~. You would need to use multiple buffer~ objects.

-Ben


January 9, 2014 | 4:21 pm

The image that I attached above shows a buffer~ with an 8 channel AIFF loaded in it?!


Viewing 8 posts - 1 through 8 (of 8 total)