Forums > Jitter

multiple errors jit.qt.grab max5

November 19, 2010 | 7:54 pm

I’ve done a search for this, with no findings; I have been exploring various jitter tutorials and externals looking for a means of generating audio from live camera input. All seem to point to use of jit.qt.grab, yet this object brings up multiple errors (and patches do not work). Here are some of the errors:

patcher attempting to load itself: jit.qt.grab
perhaps you have mistakenly named a patcher file the same name as an object it contains. this is not permitted.
newobj: jit.qt.grab: No such object
patcher: jpatchline_new: index out of range
jpatchline_plugin: box missing outlet number 2
jpatchline_completeconnection: index out of range.

All my file preferences seem in order. I can bring up help file for this object, but it too gets these errors. I am using an Education/Student version of Max/MSP/Jitter. I am on a MacbookPro OSX 10.5.8

Is this a bug or… what am I missing?

Thnx!


November 19, 2010 | 8:04 pm

Hi,

Try a clean install and if that doesn’t help, you can drop a note to support (support at cycling74 dot com)

First, remove these items:
~/Library/Preferences/Max5 Preferences Folder
/Applications/Max5

Then download and reinstall the latest Max 5 release


November 19, 2010 | 8:38 pm

poo. i was hoping that wasn’t the answer :p

thank you!


November 19, 2010 | 8:42 pm

oh yes, this was why I had hoped to avoid it… will I have to find all externals and related help files again, if re-installing? i’ve accumulated a number of add-on libraries…


November 19, 2010 | 10:20 pm

worked it out: for some reason i had a txt version of object tucked away in the patches file folder (essentially doubling the object). very strange though what that created… the result was like a matryoshka of jit.qt.grab patches (repeatedly embedded within each other).


Viewing 5 posts - 1 through 5 (of 5 total)