Forums > MaxMSP

mute/solo in channel mixer?

August 4, 2009 | 6:42 am

Hi I am new to Max MSP.
I am trying to build a mixer and want to know how to mute or solo channels without putting each channel in a subpatch and using mute~. Also, is it better to use line or line~? What is the difference with gain~ and multislider for fading audio signals in and out? Cheers,
Lis

– Pasted Max Patch, click to expand. –

August 4, 2009 | 4:04 pm

You could either use [*~] and [line~] on each channel, sending 1 or 0 to turn it on and off respectively. If you use [line~] you will avoid clicks as it works at sample rate, this isn’t the case for [line]. You could also use one [matrix~] object which has a built in fade-time to avoid clicks. Here is some javascript code for working with mute and solo states and the [matrix~] object. You might find it helpful.

lh


August 12, 2009 | 2:09 am

Thank you for your reply. Javascript is way over my head. I have the mute button working. I am still unsure if it’s better to use gain~ or multislider. I have read opposing theories…


August 12, 2009 | 6:13 am

Solos are actually a little tricky, I’ve found. There are some threads on this you can search for. My solution is spread over a complex patch so I can’t easily post it here, but it basically involves a subpatch that counts each channel that gets soloed, and at the same time re-routes those to the control room monitor, interrupting whatever else is being listened to. It also counts when solo buttons are turned off, and when the count is 0 it reverts to regular monitoring. I also have [matrixctrl] for AFL/PFL switching. Hopefully this all makes some sense. If not I can try to breakdown the patch at some point soon and send a chunk of it, but it’ll be some work to get it to make sense. I have also found that [matrix~] is your friend.

Best,
brian


August 13, 2009 | 4:31 pm

Quote:Sharing is fun !

take a look at my SOLO channel mixer…

———-begin_max5_patcher———-

Nice…

This post seems to contain a broken pasted patch. This can happen if you don’t copy the entire "———-begin_max5_patcher———-" or "———–end_max5_patcher———–" for each and every patch you paste; perhaps you missed a preceding or trailing "-" when you copied the patch? Please notify the Cycling 74 web team if you think it is a bug.


August 19, 2009 | 2:12 pm

Very nice, though the solo doesn’t allow multiple channels to be soloed (thats the hard part of course…Wink


August 19, 2009 | 2:19 pm

ONLY INSTALL THE solomute.js and solomute.help objects
http://www.estatesound.com/matsui.html


Viewing 7 posts - 1 through 7 (of 7 total)