Muting a subpatch that uses [segment~]

May 16, 2011 at 7:11am

Muting a subpatch that uses [segment~]

Sorry for not posting a patch — I can do that later if needed. I just thought somebody else might have tried to do this and could give some advice.

I have a subpatch using Tristan Jehan’s segment~. This seems to be fairly CPU intensive, so I would like to disable DSP within the subpatch, except for the times when it’s triggered to do something. I tried two things:

- [mute~] feeding into the subpatch’s left input, initialized with (1) coming from [loadbang] and set to 0 when it should be active.

- Place [begin~] before [segment~]. (I should have known this wouldn’t make a difference — [segment~] goes into a [gate], but since [segment~] outputs bangs and not a signal, it’s not a [gate~] as required by [begin~].)

I really thought [mute~] would do it, but the DSP status window reports 15-20% CPU use whether or not the subpatch is muted. CPU use for a simple patch, just feeding a cycle~ into dac~ is 1-2%.

I just tried these quickly and then discarded the failed attempts. Have to run to a lesson, but I can reconstruct the patches and post them later.

Thanks,
James

#57150
May 16, 2011 at 7:35am

Hi.

Not every 3rd party external supports [mute~]. The only completely reliable way to disable audio processing is using poly~.

On the other hand, it seems to me that 1-2% for a cycle~ and a dac~ is a lot, unless you have a very old machine. Are you sure that your vector sizes are not too small?

aa

#204720
May 17, 2011 at 1:41pm

I see… [poly~ mysubpatch 1] — Max has a sense of humor!

I’ll doublecheck the CPU usage — that was just an offhand recollection, maybe wrong. My machine’s CPU is not the newest but neither is it especially slow.

#204721

You must be logged in to reply to this topic.