Forums > Java

(mxj add dir) unable to init mxj classloader. ERROR: -50

November 30, 2012 | 8:55 pm

Dear Max folks,

I’m getting this error:

(mxj add dir) unable to init mxj classloader. ERROR: -50

and can’t use any mxj objects.

It started happening with Max 6.0.0, and is still happening after an upgrade to 6.0.8

Any advice? Below is my whole Max window.

Thanks!

John

MXJ System CLASSPATH:
/Applications/Max6/Cycling ’74/java/lib/DroneControlv0.3.3.jar
/Applications/Max6/Cycling ’74/java/lib/jitter.jar
/Applications/Max6/Cycling ’74/java/lib/jode-1.1.2-pre-embedded.jar
/Applications/Max6/Cycling ’74/java/lib/max.jar
/Applications/Max6/Cycling ’74/java/lib/maxlink.jar
MXJClassloader CLASSPATH:
/Applications/Max6/Cycling ’74/java/classes/
(mxj add dir) unable to init mxj classloader. ERROR: -50
Jitter initialized
Jitter Java support installed
Could not load class ‘net.maxhole’
Could not load class ‘net.maxhole’
Could not load class ‘net.maxhole’
Could not load class ‘net.multi.recv’


December 1, 2012 | 11:04 am

What’s in your max.java.config.txt?


December 1, 2012 | 12:57 pm

Hi Nick,

The uncommented lines are:

; specify some jvm options ;
max.jvm.option -Xincgc
max.jvm.option -Xms64m
max.jvm.option -Xmx256m

Thanks!

John


December 1, 2012 | 4:15 pm

Stupid question: you do (still) have Java installed, yes? OS X updates have a tendency to remove it.


December 1, 2012 | 6:00 pm

Not stupid at all; I had to check! Terminal tells me:

johns-laptop:Bluetooth john$ java -version
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-11M3720)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)


December 14, 2012 | 4:42 pm

Maybe try checking disk permissions first. Then perhaps try renaming your Max6 folder, installing a fresh one – does it work now?

-A


Viewing 6 posts - 1 through 6 (of 6 total)