Forums > Max For Live

my gater stopped working


k9
September 16, 2010 | 7:57 pm

Hi,

I am looking for some help on my gater I made for a M4L application. I tried to attach the patch to this message, hope this works.

What I am trying to do is fairly simple: a midi track in Live sends a note over the IAC bus that is received by Live again and arrives at an audio track where this patch is inserted. It gates the audio according to the MIDI.

I had it all working, and it still does as long as the patch is open in edit and live preview mode in Max, but when I close it to return to Live, there is no output anymore.

There is a "live.button" attached to the "notein" that stops being banged in this case.

Does the notein need additional parameters?

Any help is greatly appreciated!

K9

Attachments:
  1. Note-gaterK9.amxd

September 16, 2010 | 8:37 pm

I didn’t look at the patch, but I think you should be using [midiin] attached to [midiselect]. I don’t believe that the native objects that normally work in Max will function the same in m4l.

Cheers.



k9
September 16, 2010 | 9:31 pm

thanks I’ll look into that.

weird that it was working before though — can’t figure out what broke it.



k9
September 16, 2010 | 9:41 pm

hm, seems like I’m doing something wrong. the combination of midiin -> midiselect -> unpack of leftmost outlet gives me nothing…

what could be the problem? this isn’t even banging in a normal Max patch, even when the "notein (middle outlet) -> bang" does bang..

again thanks for any help


September 17, 2010 | 1:17 am

Is [plugmidiin] what you are looking for?

Connect it to [midiparse] (not midiselect)



k9
September 17, 2010 | 8:15 am

no, unfortunately that doesn’t work either. I am beginning to think my problem is more fundamental. I am putting the plugin into the audio-track — after all I want to gate the audio.

I use another track set to "MIDI to" IAC bus. Another MIDI-track receives this, but my aforementioned audio-track does not.

so far so good.

But I had it working yesterday. Only when I needed it (in a theater play run through, of course) it failed me.

I could render the whole thing in Max but want to be able to modify the tempo of the gate from 70-170 bpm — so getting this to work would be a huge improvement..

I’d appreciate if someone who knows more about M4L could look at my patch and tell about my mistakes in setting things up. I feel like I am overlooking something silly…

Thank you!
K9


September 17, 2010 | 9:45 am

Your problem is that M4L audio devices by design can’t receive midi.

But since you are on mac, the solution is here.

http://cycling74.com/forums/topic.php?id=28541



k9
September 17, 2010 | 2:31 pm

thank you. another thing to try out. And time for a petition for this cause to Cycliton…


September 18, 2010 | 9:40 am

Search maxforlive.com. Someone did exactly that using send and receive.


September 18, 2010 | 11:12 am

Send/Receive can only be used if accurate timing doesn’t matter.
As confirmed from the developers, it introduces unpredictable latency.


Viewing 10 posts - 1 through 10 (of 10 total)