Forums > MaxMSP

My standalone app (re)jouney

December 23, 2010 | 5:34 pm

I made a real basic standalone app in college, but using vst’s has me confused. So greed my little forum journal on getting my stand alone working.

Using max4.6/jitter1.6 on c2d macbok pro

First problem – Vst’s. Specifically from native instruments. Do I have to write a script for it to initialize/find it?

Second problem – scripts. How hard will it be to fine tune things like the max window showing/locking window sizes?

Third problem – why did my first build not recognize (*~)?


December 24, 2010 | 3:56 pm

hrmm =/ I really don’t know where to start with these. I’m more than willing to do the research, but it seems I’m not finding the nitty gritty.


December 24, 2010 | 11:06 pm

not sure how it worked in 4.6 but you should be able to send the "plug" message to the vst~ object and then load the plugin manually(from your hard-drive’s plugin folder or wherever the plugin file is located). otherwise, it’s possible that the vst plugin you’re using is not compatible with the vst specification around which the vst~ external was written. if you’re using NI plugs, they might be on vst spec 2.0 while the old max4.6 vst~ object is still on vst spec 1.0.(i’m not actually aware of which specification happened when, but just giving an example to let you know one ‘kind of’ problem people have run into… especially when using the old version, Max4.6)

as for your second problem… again, i’m not sure what it’s like on the old max4.6 but in max5, it’s very easy with the thispatcher object(but if you’re talking about ‘real’ scripting as in javascript or python, i’ve heard it’s easy to do there, too, search these forums specific to those if you need them. Max5 has more in terms of these scripting environments than Max4.6, your mileage may vary.)

as for your third problem… this is always difficult to answer. it could be you had another file with the same name, or you kept it in the wrong place. i’d recommend writing to support for something like that unless you have much more detail on your build process…

hope that helps or that someone else with more knowledge finds this bump and helps you further.

best of luck.

________________________________
*Never fear, Noob4Life was never here!*


March 15, 2011 | 9:44 pm

Hey! Sorry for being AWOL, but I have a good reason!

anyway I wanted to thank you for your help. I’m gonna try and go through again and see what’s going on, taking you’re thoughts in hand.

Notes:

-if I don’t do anything, it’s builds the app fine, but can’t find any of my [sfplay~] sound files, my [kore.vst~], or know what the [*~] object it. But if I try to add the folder that the vst/sound files are in it freezes. Wha?
-I opened up a different project with the same goal, but no synths, just [sfplay~] and sound files. Noticed that it still cant find the [*~] object. However, I don’t use that object in this other patch. Why is it trying to find it?
-SO I went an noticed that my externals folder doesn’t have that file, but I can still use it in Max. Is it located somewhere else?

Thanks again. I didn’t think to send support an e-mail, but will hold off for a bit.

btw, since you sound like you have max5, does it support building stand alone apps like 4.6?


Viewing 4 posts - 1 through 4 (of 4 total)