Forums > MaxMSP

Nathan Wolek's grain.bang~ issues.

January 16, 2007 | 1:18 pm

I’m using the mono beat attached with the grain.bang~ object I obtained from http://www.lowkeydigitalstudio.com (granular toolkit)however, it doesnt want to play back each grain correctly and the playback is either non existent or the sound is muffled and has a lot of crackling effects convolved with the signal.

Can anyone help me understand what is going on?

Thanks

max v2;
#N vpatcher 280 44 1556 800;
#P toggle 631 221 15 0;
#P window setfont "Sans Serif" 9.;
#P window linecount 1;
#P message 631 241 68 196617 winInterp $1;
#P toggle 558 221 15 0;
#P message 558 241 68 196617 sndInterp $1;
#P newex 454 405 140 196617 buffer~ window emptybuffer;
#P button 779 395 15 0;
#P user ezdac~ 631 427 675 460 0;
#P message 773 302 14 196617 1;
#P flonum 771 328 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 728 313 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P flonum 678 310 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
#P button 645 317 15 0;
#P newex 630 356 158 196617 grain.bang~ emptybuffer window;
#P message 352 371 43 196617 replace;
#P newex 454 431 103 196617 buffer~ emptybuffer;
#P connect 1 0 0 0;
#P connect 12 0 11 0;
#P connect 3 0 2 0;
#P connect 11 0 2 0;
#P connect 13 0 2 0;
#P connect 14 0 13 0;
#P connect 2 0 8 0;
#P connect 4 0 2 1;
#P connect 5 0 2 2;
#P connect 7 0 6 0;
#P connect 6 0 2 3;
#P connect 2 1 9 0;
#P pop;


January 16, 2007 | 4:44 pm

I think the problem is that you specified the soundfile "emptybuffer" as the file to load into the windowing buffer. Try changing that to one of the windowing files included with the kit (like gauss) and see if that helps. Look again at the help file for grain.bang~ and see if that plays correctly for you. If it does notice how the sound to be granularized is in one buffer~ called sample in the help file, and the window’s shape for the envelope over each grain is called window.

Quote: Dr. Spankenstein wrote on Tue, 16 January 2007 05:18
—————————————————-
> I’m using the mono beat attached with the grain.bang~ object I obtained from http://www.lowkeydigitalstudio.com (granular toolkit)however, it doesnt want to play back each grain correctly and the playback is either non existent or the sound is muffled and has a lot of crackling effects convolved with the signal.
>
> Can anyone help me understand what is going on?
>
> Thanks
>
> max v2;
> #N vpatcher 280 44 1556 800;
> #P toggle 631 221 15 0;
> #P window setfont "Sans Serif" 9.;
> #P window linecount 1;
> #P message 631 241 68 196617 winInterp $1;
> #P toggle 558 221 15 0;
> #P message 558 241 68 196617 sndInterp $1;
> #P newex 454 405 140 196617 buffer~ window emptybuffer;
> #P button 779 395 15 0;
> #P user ezdac~ 631 427 675 460 0;
> #P message 773 302 14 196617 1;
> #P flonum 771 328 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P flonum 728 313 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P flonum 678 310 35 9 0 0 0 3 0 0 0 221 221 221 222 222 222 0 0 0;
> #P button 645 317 15 0;
> #P newex 630 356 158 196617 grain.bang~ emptybuffer window;
> #P message 352 371 43 196617 replace;
> #P newex 454 431 103 196617 buffer~ emptybuffer;
> #P connect 1 0 0 0;
> #P connect 12 0 11 0;
> #P connect 3 0 2 0;
> #P connect 11 0 2 0;
> #P connect 13 0 2 0;
> #P connect 14 0 13 0;
> #P connect 2 0 8 0;
> #P connect 4 0 2 1;
> #P connect 5 0 2 2;
> #P connect 7 0 6 0;
> #P connect 6 0 2 3;
> #P connect 2 1 9 0;
> #P pop;
>
—————————————————-


Viewing 2 posts - 1 through 2 (of 2 total)